Mission planner disarms after several seconds ; cannot arm w/o MP

Hi - I am trying to run a single motor in feedback control via accelerometers through pixhawk and running into some problems arming it autonomously. Here things I have done so far:

  1. Connected ESC to Ch1 ; UBEC (to arm opto-coupled ESC @5V) via Servo rail #6) ; 3DR @ power; Arming button ; Buzzer; USB
  2. I have tested the ESC & drive with a Spectrum DXe remote. Drive works fine on it’s own.
  3. using APM 2.0 mission planner connected through com2 to Pixhawk; loaded Firmware for Quadcopter ("+" layout as this is what will come closest to what I will have with 3 more drives I am planning to get once the single drive starts working)
  4. Calbrated Accelerometers; disabled Compass; disabled ARMING_CHECK to overcome the “RC not calibrated” issue;
  5. The Acc sensors are life in the Primary flight display ; Set CMD 20 (RTL); Set CMD 11 (Alt Hold); Set CMD 400 (ARM); Result: The system gets armed and I can control the motor speed by pivoting the Pixhawk around the roll axis. I was playing with ACC sensitivity and max speeds - all seems responsive and which starts making me happy. However 2 problems going forward:
    6.1 The system automatically disarms after ca. 5 seconds. So far my attempts to figure settings on my own / searching the web for potential causes were not successful.
    6.2 My goal is to run this autonomously, and my attempts to disconnect USB (MP…), and try to ARM the system manually via arming butting are not successful. Moreover, the Arming button I received (ordered from robotshop) with the Pixhawk is not the one shown in many docu’s on the web (It is a microswitch on a small circuit board)- and I am not confident whether it works at all (don’t hear the Beep& the LED blinking/colorscheme does not change @ depressing (short or long does not matter) I tried to disable the Arming button for testing purposes, but all information I found so far leads me to a MP with settings in an “advanced setup” tab, which is absent in my APM2.0… (I have only “Basic Params.” and “Standard Params”)

Any thoughts on this would be great.
Thank you in advance.
PS.: here a picture of my Pixhawk and immediate periphery for now.

Don’t know about all of this but I do know that in Copter FC, will disarm if no throttle input given within 5 seconds from arming. As for Mission Planner -while not connected to the FC,-go to the CONFIGURATION Tab and use the LAYOUT Drop Down Box to select ADVANCED to get to all settings…

1 Like

Joe-thanks for the hint on the advanced settings access. very helpful.

Hi - this is to share how I managed to arm my Pixhawk autonomously after all:
Disarming after 5s: Arm indefinetly through (DISARM_DELAY=0)
Enabled Arming switch ARMING_CHECK=1

System now arms/disarms via switch and off the laptop. Here a short clip

Thanks for the hints I got here before I got to this stage