Servers by jDrones

Mission Planner crashes when graphing an event log


(charles linquist) #1

For several versions, Mission Planner has crashed when I try to graph an event log. It will replay the log just fine, but gives the following error any time i try to graph a log. Here is the error.

Mavlink%20Error%202


(Michael Oborne) #2

is it always the same log? or all logs?


(charles linquist) #3

All logs. The only way I can graph a log is to use an older version on another computer.


(Michael Oborne) #4

can you try the latest beta MP?
i have a feeling its fixed. but want to confirm


(charles linquist) #5

I tried the latest beta and it doesn’t work.

I’m running build version 1.3.6681.2780 (latest beta) on my laptop. I haven’t been able to use my laptop for analyzing log files since I upgraded from 1.3.52.0

My desktop machine is running build 1.3.52.0 That works fine.

I suppose it could be a difference in the machines, but I’m reluctant to upgrade my desktop to see if it “breaks”, since my desktop is the only machine that will analyze telemetry logs. Both machines are running Win10/64.

I did notice that the two machines store the log files in different places.

My laptop puts the logs in

C:\Users\Charles Linquist\Documents\Mission Planner\logs

While my desktop puts the log file in

C:\Program Files (x86)\Mission Planner\logs


(charles linquist) #6

Michael,

I have tried and tried to graph the telemetry logs. But nothing works -
unless I go back and choose an earlier version of MP.
1.3.51 gives a “compile error”, but does work. Later versions give the
error message shown below. I have tried everything, including:

Totally erasing MP and re-installing.
Installing on a different computer (But all my computers are running
Windows10/64)
Installing and running MP in "administrator mode"
Choosing a different path for the log file.
Using a different flight controller to generate the log file.

But NOTHING works.

The program loads and “plays” the log file just fine, but will not graph it.

So now I have no choice but to go back to version 1.3.51

Charles Linquist

Attached is a screenshot of the error I get.


(Michael Oborne) #7

I release a new MP that should resolve this. the previous fix was upgrade to beta MP