Mission Planner crash while connecting to multiple vehicles

I have simulated Quad in 10 machines and successfully connected to all the machines from the master using TCP.

Opening the hidden function using ctrl+F and clicking on Swarm button work only if i have connected 3 machines in simulation but not 10 machines…

Can you please advise me with a solution to get rid of the above error???


what version mission planner? what links types. i need more information.

Version 1.3.61

Its a LAN network…

10 machines are running Mission planner quad Simulation

connection to the 10 machines via TCP using their LAN IP was successful on the random ports 5762 or 5763
but SWARM windows throws the error

are you adding the same drone twice? ie on 5762 and 5763 ?

No… but…

for example…

if i have to connect 10 devices… in LAN network in the range to…

then i have connected like on 5760 on 5762 on 5763 on 5760 on 5760 on 5762 on 5763 on 5760 on 5762 on 5763


the problem solved…

In ““Full parameters list”” i edited the SYSID= 1 to n

disconnected all the machines…

connected all again…

each MAV was assigned with different ID,

and now it works fine,

Hi itzmejawad,

I’m new to Mission Planner. I need to do the multiple drones (> 20) experiment for my paper. can you help me to set the multiple vehicles in mission planner? I got only 3 vechicles with, 5762, 5763.

goto the MP simulation screen, and click Copter Swarm. and type 20. NOTE this requires alot of CPU power

1 Like

Hey @Thu_Ra
As suggested by @Michael_Obornegoto the MP simulation screen, and click Copter Swarm. and type 20.
But with an i7 processor, 8gb ram and 2 mbps internet download speed … it takes minimum of 10 minutes to get all the 20 copters get connected

Other way to do is… In Ubuntu… clone the Arducopter github folder as 20 folders… like Arducopter1 to Arducopter20…
Then you can use -I1 to -I20 along with the simulation command to get 20 vehicles out…

./sim_vehicle.py -v ArduCopter1 -I1 --out=udpout:
./sim_vehicle.py -v ArduCopter20 -I20 --out=udpout:

Good Luck :wink:

i can run 10, no issues, but 20 causes problems

1 Like