Mission Planner Compass calibration screen problem

I have 1.3.10 MP.
I tried compass calibration and after I click the “Live Calibration”, a window pops up to click on “OK” then another window replaces. For most of other images that I have seen, it shows x, y, axis with bunch of dots showing up. For my case, it’s just a black box without the x, y, z axis and states “Got 3 samples more data needed” then the count doesn’t change at all. It just stuck there.
What am I doing wrong?

Any words would be much appreciated. Thanks!!!

*Image attached

please update your graphics card driver

I have the exact same problem, I only have the flight board connected, nothing else connected to the flight board. I still couldn’t figure out what’s the problem. I have tried all different kinds of computers, still the same error. Could it be board problem?

I had the same problem, the way i solved that was to turn my transmitter on then go into the calibrations.

very good call motorman29.

must be that you have a failsafe enabled, and that prevent the AP from doing anything.