Mission Planner COM Ports

I’d like uartD to map to a COM port on my Windows machine when I run a simulation in Mission Planner. It’s seems well documented how to map uartD to a serial port with cygwin and linux but I can’t seem to find any info on how to do this in Mission Planner. I’ve tried running ArduPlane SITL manually (I found it in the Documents\Mission Planner\sitl folder) but I don’t know the syntax. Is it “–uartD uart:COM3” or something like that?

MP has a box to add extra commands when the sim runs. you will need to add your --uartD stuff in there

Thanks. Does anyone know the “path” to a serial port that get populated in that extra commands box in Mission Planner?

i havnt tested but try


It needs to be \.\COM6

There is something strange though…when I enter this I can see ArduPlane attempt to open this COM port and then hang. If I open the COM port using TeraTerm first, exit TeraTerm, and then open via COM port via ArduPlane, it does work. I’m guessing TeraTerm puts the device or driver in some state that the SITL finds friendly. I tried Putty but it didn’t work. I don’t think this is Mission Planner specific as I tried to start ArduPlane manually from the command prompt and got the same behavior. If someone knows why this is happening and can tell me how to put the COM port in a state that makes ArduPlane happy without resorting to executing TeraTerm that would be appreciated.

could be a baudrate issue or something else, hard to say