Mission Planner cant connect to Mega 2560 Help needed "Solution found see below"

Hi everyone. I hope someone can help.
I can get everything to work on my in 10 laptop but
I am trying to run Mission planner on win7 32bit Business version op system laptobwithout luck.
I have tried everything I can think off so its not like I havent reached the end.

I purch a full new version of the Win 7 op syst installed and updated it.
I installed MP 32bit x86 and installed Netframework 4 as directed.
The MP software loads but I just cannot get the driver for my Cheerson CX20 mega 2650?brd
Win 7 states that the driver is missing, so I pointed it to the driver folder in MP no luck.
I tried the MP wizard which asks if its Linux, APM, PIXhawk I tried everyone still no luck.
Have I the right MP software its the MP x86 MSI sept 23rd? anyone know wht Im doing wrongly?

Brain has turned to sago

Well after 14 hours Today (abot 36 straight hours if you include the mis installs, win upgrading etc). I have acheieved Nirvana :smiley:

IT works , it works!
The solution windows could not install or find Cheerson CX20 Arduino Mega 2560 driver and they didnt apper to come with Mission Planner.
I eventually (didnt work firt 4 searches) found Arduino drivers here
Downloaded and installed each step/item.
And It worked CX20 found on COM4 adrunino mega 2560. Mission planner shows all parameters and life is sweet :smiley: