Mission Planner bug in gimbal setup page?

I am having problems getting my new gimbal setup.

Pixhawk 3.4.4 firmware Octo coaxial
No gimbal control works

Install 3.4.4 quad
Safety switch disabled
Brd_safety bitmask disabled
All aux outputs set to PWM (6)
Gimbal setup page RCin6 tilt, RCin7 roll, RCin8 pan
RCout Tilt 6, Rcout7 roll Rcout8 pan. GImbal controls on Motor 6,Motor 7 and Motor 8
Everything works
Change Rcout Tilt 9, RCout Roll 10, RCout Pan 11, switch gimbal controls to aux 1, aux2, aux3 from Motor 6, Motor 7 Motor 8.
Everything works
Change Mnt_RC_IN_Tilt =9, MNT_RC_IN_Roll = 10, MNT_RC_IN_PAN =11
Everything Works
Load Octo coaxial firmware
Check settings remain as before, They are same settings.
Nothing Works.

Troubleshooting further I installed Quad 3.4.4 and got the gimbal working on the ch9,ch10,ch11.
I then installed Oct quad 3.4.4. Recal’ed the Radio and nothing works.
I then restored Quad 3.4.4 and ReCl’ed the radio and everything works.
I then installed Hex 3.4.4 and reccal’ed the radio and everything works.
I then installed Octo 3.4.4 and recal’ed and nothing works.

I then tried to troubleshoot when the change took place and when to load Octo Quad 3.3.3
Mission Planner times out in/blows up trying to get any archive firmware versions.
I went to firmware.us.ardupilot.org to manual download an older version to test and it appears that all the older versions have been deleted from the archive.

I am unable to troubleshoot further due to lack of resources.

Replaced Pixraptor fc with “pixhawk” 2.4.8. Same procedure with same result. With 3.4.4 it works in quad but not in octo.

Now that I able to get to the archive I tried moving back until it works. It works at 3.2.1 so it must be a firmware problem. Moved request to the Copter 3.4.4 forum.