MISSION Planner BETA update not working. 403 Error ( Forbidden )

Mission planner beta update is not working, I have tried on two different computers and get the same error:

403 ( Forbidden )

I am guessing the update site it links to has been locked ???


I have done this but a crtl click update will not update to latest’s master is there a reason for this? I have also uninstalled and reinstalled MP what has changed in the recent month that has broken MP update function. As @Michael_Oborne said it was appveryor and that things should clear up in a 24hr period. It has been at least a week on this end and MP update is still unresponsive with the 403 forbidden even when using the above link post. will MP update feature work again, if the feature isn’t going to work it should be removed as to not confuse user.

If you’re still getting the error, you haven’t followed that thread. Download the zip file and overwrite your installation as Shawn described there.

1 Like

Works for me. Yesterday’s Rev:

After pushing the Update to latest beta button today:

@Yuri_Rage, @dkemxr
crtl-click will not update to latest master it still throws forbidden. even after following above instructions. will this functionality return at some point? @Michael_Oborne is the crtl click update to functionality going to return? I feel this is within line of the original posters topic and does not return a new topic

@Michael_Oborne, confirmed here as well. Stable and beta updates work fine. Latest master (ctrl-click) is still broken, likely due to appveyor references.


I can confirm that both stable and beta work perfectly after doing the above instructions. I just sometimes like to update to master as there are some minor tweaks and what not that often help and its become a habit and has never caused any issues. just was wondering if it will eventually come back.