Mission Planner Beta (Linux)

I need a link to the mission planner beta with the correct windows speech files. I am installing onto Linux and read that the solution to the systemspeech files error was to use the beta client. Only problem is http://firmware.ardupilot.org/Tools/MissionPlanner/beta/ does not work. Please help.

should be fixed now.

1 Like

Just tried that an got a 404 error

Good luck with speech.
Had it working using “Wine” and when installing speech synthesiser in Linux (in my case Kubuntu) eventually found after many days of research speech would only work if system is set to “US” . Any other country setting wouldn’t work at all as the speech synthesiser required is so old it will not accept any other language setting.

  • However, since last year MP is made to work using MONO within Linux. Whilst some elements still work under Wine certain display elements only work with MONO since version 72.
    Speech won’t work at all since then as I understand there is a lack of support for speech within this current version of MONO.
  • Also been having screen related problems as mentioned in another post over a year ago:
    (Have you encountered the same?)

When reviewing a Dataflash-Log the buttons for various options I.e. displaying/removing status messages, errors, events,… will be hidden once the Data Table is activated. Unfortunately this will not reset when MP is re-started.
Also unable to un-check the Data Table option as this is also gone. - Hence stuck with this display option until re-install or version upgrade.
This has been already been observed in version 1.3.74
(Could this be linked to my specific screen resolution -1920x1080 ?) → No, as I’ve tried on different computer with same result.

…Unfortunately re-sizing the table or the chart doesn’t fix it as gap between the two remains the same no matter what. (hence buttons not visible)