Mission Planner 1.3.7: a file is missing

Hello everybody,

I searched on the forum but unfortunately I didn’t find similar issue than mine.
I am currently building a quadcopter using a APM 2.5 flight controller and I am facing an issue with Mission Planner 1.3.7. After downloading all drivers and selected correct COM port and speed transmission, I intented to establish a connection with the controller. All worked well, it could get all parameters needed until the progression bar is full (message “Done”). But just after I got an error message: "Can not establish a connection. Could not find file ‘C:\Program Files (x86)\Mission Planner\fwversions.xml’."
Indeed, the file fwversions.xml does not exist on my computer, I tried to re-install MP but I always get the same message, it seems that Mission Planner installer never install this file. An old version (1.2.54) worked quite well on my computer.
If someone knows were I can find this file it would be greatly appreciated. I run Mission Planner latest version (1.3.7) on a 64-bits Windows 7 Enterprise operating System.
Thank you very much for your help! :slight_smile:

that file is automaticly generated when mp starts.

Thank you very much for your answer, nevertheless it seems that for me it was not created starting MP since it is MP which asks for it. I checked in folders and the file is not here. But if you use the same version of MP could you send me a copy of the file? I would put it myself in the folder.

I will reply myself, my problem is finally solved.

If someone faces the same issue:
What hapenned was that I was connected to a private network and Mission Planner couldn’t have full access to the internet to download what it needed, and it couldn’t create the missing file. I connected to a public network and gave full access to the internet to MP on every network to be sure and the problem was solved, th fwversions.xml file appeared in my folder.

Thank you for your help anyway! :wink:

I just got the same problem 1.3.7 but I don’t understand what you are saying to do

The problem came from my network or firewall settings, there was an issue with the proxy and MP could not have access to all it needed. Try to connect to the internet through another network or set the firewall to allow MP to do what it want with internet connection.

Checked my firewall settings and am wide open for this, plus nothing had changed except I upgraded the Pixhawk to the beta firmware, of course since it won’t connect I don’t know how I would get it back to the original firmware. Any suggestions?

Well, the only difference with me is that my flight controller is an APM 2.5 and not a Pixhawk.
Here is a link to download a copy of the file fwversions.xml, try to put it in your Mission Planner directory, who knows…