Mission Planner Not loading high res google images

Hi Guys and girls (are there girls here?)

I know this has been dealt with many times but no one really gives any solution. I am using the latest version and also installed the beta version but they are both the same.

Many areas won’t give me high res images on google maps. I installed APMPlanner2 and it works fine but Mission Planner won’t give me close to ground high res images. Of course they are fine on google earth too.

The weird thing is is will download the imagery for some areas. I tried Miami, FL USA and it works fine. Then I try London, UK and it won’t work. I try Cape Town SA and it’s fine then I go to Johannesburg or Kimberley where I live and it won’t work. All these places work fine in APMPlanner2 though… so it has to be something stupid right?

I am running Windows 7 64 bit. First time using Mission Planner - just learning. It’s a bit hard without good maps though. I’m not a pro yet but computer savvy. Have tried to remove the cache folder, restart, reinstall etc. Will try on another laptop later but that one runs Win 8 64 bit.

Thank you kindly for any help.

Yesss!!! :smiley: there are girls here :wink:
I have the same problem with same windows, on latest vers; I supposed that it was only my problem, so now I’m using Bing satellite map and works well. Perhaps an issue?

That is good to know!!! :wink:

I did try bing satellite and while it works just fine it doesn’t have nearly the detail google has and is way older. The park that I like to fly in does not even exist on the bing maps yet and it’s been here for over 2 years already.

It must be a bug because if I use APMPlanner2 the google images work fine… unfortunately APMPlanner2 has a long way to go before it will work as well as Mission Planner :frowning:

Who do we have to beg to get this fixed? I tried it on my Win8 computer and it does not work on that either…

Someone else can check this please? I’m running a W7 64 bits, with older vers I didn’t have problems. Any idea in our pc config to see? Thank’s

So despite the fact that these maps work on APM Planner and Droid Panner no-one can help with this? C’mon people can someone at least refer us to a person that can help? :open_mouth:

The devs aren’t only here 24/7 :slight_smile:.
Did you check with your browser if GMaps actually has hires pics for your area?

Yep, my previous post clearly states that the maps work in DP and AMP2. And of course they do work in Google Maps and Google Earth. (I’m new… not retarded! :wink:

If I can figure out how to feed Mission Planner with maps from another program that could work too.

Other map providers like Bing and yahoo do work fine but are so very outdated that the place I am standing in does not even exist.

I found the problem, I am however clueless on the solution.

Okay so here is how google maps works in conjunction with MP:
Google has a specific URL attached to each individual tile for every image that it has in it’s satellite. At every zoom level google divides these images into 256*256 squares and then the software in google maps/earth puts them back together for you as you requesting them by browsing. Mission Planner does the same thing, as you zoom in on an area MP sends a server request to Google that allows you to see the image that you’re requesting.

Here is what is going wrong:
It appears that google maps for some of us is exclusively providing a 404 error (typically indicative of a bad URL request)[attachment=2]1.png[/attachment]. Indeed this is a bad server request provided by Mission Planner, in MP’s defense it wasn’t always a bad URL. Google is constantly updating various aspects of their satellite data, each time they do, they change the URL. This is why we are getting the server error.

Geeky technical info:
Mission Planner 1.3.5 build 1.1.5260.33055 is currently requesting v145 of google satellite image data. Currently google’s satellite data is working on v150 and 99% of v145 links no longer work. Using Fiddler browser debug, I was able to determine that this is the case.[attachment=1]2.png[/attachment] And further confirmation is reached when I copy and pasted the link into my browser, initially received the 404 error, changed to v150 and received the exact requested image. [attachment=0]3.png[/attachment]

Why I can’t fix it:
I’m not certain how mission planner decided to follow v145 instead of v150, it may be based on my browser history, or google earth, or it may be hardcoded into the software itself. This is as far as my skills go.

please try the latest beta MP

Knightg180 you are a genius! Now I at least have a manual way to get the tiles I am looking for. Hopefully now that the problem is out in the open it can be addressed. Hoe do we get this to the attention of the programmer? Can someone please pass this on to him/them?

I did the beta update 2 weeks ago and problem was still there.

The guy who posted just before you is the developer

Ah ok I was on my phone and did not see his title. Thank you Meee1 and everyone else for your input. After loading the latest beta update the problem does indeed appear to be solved. At least on my end of the globe! :smiley:

Mission Planner 1.3.16 is doing the same thing again. I have a section of town that loads detailed images and everything to the west of a line only loads high altitude tiles. Google Earth is fine, and Bing maps also, just not the detail and not very recent with Bing.

Do I Wait for the next update?

Thanks to all the DEV guys for working on this!

I am running MP Ver.1.3.32 bld 1.1.5736.30798 on my desktop (Win7 64) and it works fine, no issues. :smiley: I just loaded the same version MP onto my laptop (win7 64) and I am having problems with high res google Sat. Maps / HybridMap. I tried updating my Laptop to MP Ver. bld 1.1.5781.34785 but I still have the same problem:

GoogleSatelliteMap: "Exception: The Remote server returned an error (404) Not Found"
GoogleHybridMap: Blurred view at higher zooms (aprox. 60% zoom) and some blocks of the map are all white

When I select BingHyridMap: I get a full res. map that I can zoom to a level that shows detail i.e. aprox. 85% but the maps are very old (image is several years old).

I have read the forum “Mission Planner Not loading high res google images [SOLVED]”. When I select the MP “Help, Check for Updates” or “Help Check for Beta Updates” the MP automatically updates and I still have Ver. bld 1.1.5781.34785 and the problem is not resolved. Since my Desk Top computer does not experience this problem there must be some other issue.
Any suggestions?