Mission for ArduPlane

I am puzzled as how to define a mission for my ArduPlane. I have no problems with the Mission start, Mission Takeoff or waypoints. The problem is defining the landing. I select Land and get a loiter point which falls a long way from the intended landing point. I have changed some of the values eg. altitude and diameter more suitable for my purposes. Unfortunately I can not proceed further. Can anyone explain this or point me to a video or explanation. I can only find explanations for Mission Planner but can not use this platform as I use a Mac computer.
Many thanks

There is quite a bit of configuration, tuning and trials to do to get a good Auto Landing. It’s not a Ground Control Software problem.
Auto Land

Thank you dkemxr, I think my message must not have been clear.
I know form experience that getting the flying characterises for autonomous flight are challenging. I have three projects at the moment no 1 a flying wing it performs well, 2 a tailsitter it is hopeless and a plane fitted with tricycle undercarriage and this is flying well. I am not saying that there is a problem with QGC but I can’t define where I want the plane to land using QGC. Presently I use missions provided by a colleague who uses Mission Planner.

The include screen shot shows my dilemma, The plane is sent out of bounds and lands across the runway! How do I fix this problem?

QGC sets up an approach path for a landing. It basically creates two waypoints. You should be able to grab WP 5 (loiter) and move it around to set up the approach path and adjust the parameters on the popup window to set height and GS. As you move WP5 it should orient the landing WP for you.

Thanks Alister,
I want to clarify one thing. I have no issues with QGC but I personally do not know how do the landing thing in QGC. I can’t move WP 5, don’t know where to set the altitude and don’t know what GS is, in short this is the help I need.

Thanks, every little bit is helpful

In the first image I’ve dropped the landing waypoint and the landing route has shown up in an arbitrary position. In this landing from the east. I can grab (in my example) WP 12 and rotate it around. It will pivot around the landing waypoint. Once it’s in the direction you want it click “done” in the waypoint list on the bottom right.

Now the waypoint box will change and you can adjust all the rest of the parameters for the approach. (alt and GS) Remember this is just for the plan, so you’ll need to select a glide slope that’s appropriate for your plane. You can also turn off the loiter circle if you don’t want it. And as always you can still drag that waypoint around to adjust the direction.

Thanks Alister,

Naturally I have read your reply. It make sense and I now need to play around with it for a day or two to fully understand it. Then comes the ultimate test will my plane obey and play real nice, sure hope so.

Thanks again

That’s the hard part. I’ve just spent the weekend fighting with that. Jury is still out if I was successful or lucky.

Take the time to go through the setup for autolanding, and make sure you’re familiar and ready to abort the approach if things aren’t going as planned.


1 Like

Thanks Alister, It put a smile on my face to read that you like me are fighting the good fight, will it fly PROPERLY ? I have flown my plane around 20 times and doing missions i,e flying circuits. To date takeoffs have been started using FBWA then switching to Auto and it landing roughly where intended. Now for a full autonomous flight! I have done a few trial QGC missions but sill have to learn quite a bit.


1 Like

I realise it is now about 7 weeks since my last post but I am agin having problems with QGoundControl mission planning. When I plan I cannot complete the Landing definition. It is as if I am missing a button/icon the click. I used to be able to get to a stage when I could view all entries for the waypoint but this option no longer shows. Sorry I cant clearly explain the problem. I have the latest version of QGC and the the latest stable version fo the ArduPilot firmware on my flight controller.