Mission feature is affected once geofence is enabled

Hello All,

I am working on a Linux System. I had setup the SITL environment and started testing the features one by one. The Mission feature by giving way points runs perfectly without a geofence. But after a geofence has been enabled, when the copter crosses a line formed my two way points. It switches to RTL.
I am not sure as to why this happens. Any suggestions?

It’s probably crossing the geofence and so it goes home.


Nope I don’t think that is the reason. Please see this video. https://youtu.be/RhyuwmMbyPw

I uploaded this just now. I think you will get a better understanding. I really am wondering how this is possible. I also tried a larger geofence, which shows a similar behaviour.

If you had showed the MAVProxy window, we might get an idea, this way I can’t say anything about it.

Have a look at this video https://youtu.be/re1M9TINVkQ. I have simulated a similar environment.

OK, I’ll need to see the log, there is no clue in the MAVProxy window that I can see.

However after trying to get this right last night, I found that the geofence and waypoints work fine just upto a certain distance/terrain on the map. And after that the copter heads back to RTL. I feel there is some default setting that gets activated when the geofence is enabled. This default setting does not allow the copter to fly beyond a certain area, thus making it come back to RTL irrespective of its position. I tried giving waypoints really close to the default start position and made a small geofence around them as well. It just worked fine. So I am guessing that there is some default parameter getting activated here. Any ideas??