Mission commands are not executed

Dear all,

I tried following waypoint data with my airboat.
test1.txt (1.4 KB)

This is the Flash log data.

This figure shows result of auto mode.

It appears that ”Mission: 1 Change Speed" was executed.

However, the subsequent “Mission: 2 WayPoint” was not executed.

At this time, the boat went in a different direction than Waypoint.

Then I turned off the power, rebooted, and left it for 5 minutes before Arm and Auto, and the boat autopiloted normally.

If a Mission is not executed in this way, what is the cause?

Thank you.

Based on your log, it appears the boat is tuned extremely poorly, possibly even suffering from reversed outputs. It’s hard to tell from the brief data supplied.

Follow this guide carefully:
First Drive with Rover — Rover documentation (ardupilot.org)

Dear Yuri_Rage-san,

This boat has already been adjusted.
After this, I rebooted it and left it for 5 minutes.
Then I ran the same mission as uploaded to FC and it worked well.

Successed Flash log

I tried when GPS status was 3 and when it was 4.

In both cases, Auto mode usually succeeds.
However, sometimes the mission command did not proceed to the next step, as it did this time.

Please give me your comments.

Thank you.