Missing Position Mode


I just updated Mission Planner, and now my “Position” mode is missing.

DO you know how to add/implement it in the flying mode list ?



I have same issue. Missing position mode.
Please help. Position mode is wery usefull for me to make high altitude videos.

you are connected? as position mode is still in there.

I confirm you Position mode is not there.

I have this version of mission planner : 1.2.97, on my previous version it was there, and it was very usefull.

I just checked mine a while ago and the position hold is missing on my mission planner too…

I wonder what happened.

I also like Position Mode, and it’s gone!

However a workaround is to set FLTMODE2 to 12 (or FLTMODE3, 4, etc. depending on where you want it on your switch) in the Full Parameters screen. 12 is the missing flight mode, Position Mode. It shows up as blank in Flight Modes screen and won’t let you save the modes with the blank in there. But you can write the parameters in the Full Parameters screen.

I’ve tried it and it seems to work–the Position Mode code seems to still be in there.

Not sure where it’s gone but here’s the description: copter.ardupilot.com/wiki/ac2_positionmode/

Maybe its redundant as Loiter does the same thing except that it also alt_hold’s but you can still climb or descend with throttle stick, just not so fast?

from what I can tell it looks like in AC 3.2 position mode will no longer exist.

and this is where the problem is coming from.

For what it’s worth, the workaround I suggest does not work. I’d previously tested it on a quiet day, but today it was windy, I was not ready, and I have a pile of wreckage to prove it doesn’t work. So 'long Position Mode.

need to updated mission planner to beta version, and the problem is solved.

@chilkata how did you get it right, only change FLTMODE to 12 in beta?