Missing parameters in mission planner

I am following this guide , but I am missing the parameters below.
What do I do here? I think the parameters are for copter firmware, but link says rover… I am running v4.1.5


Some parameters wont show up until you enable the feature and restart.

Like the AVOID_ENABLE parameter…

I have it set to 7, just as the guide says. I also restarted but the parameters arent there

Perhaps you are right and the Wiki for Rover copied some of the Copter parameters. I don’t see those parameters in Rover, even the latest Dev version.

So how does the obstacle avoidance for rover even work when you cant set these 3 extremely important parameters?

One parameter controls wether the vehicle should stop in front of or slide past the object, the other two controls how far away from the object it should stop/slide past and how much distance it should keep from the object. Whats the boat even going to do when you cant set these parameters?

Now I wish I hadn’t wasted all that money on the camera and companion computer…

It sounds like you are talking about Bendyruler avoidance. There are separate parameters for that.

1 Like

At least theres still some hope left. I am reading about Bendyruler avoidance. I bought the depth camera and companion computer to have a simple working obstacle avoidance.Hope I can get rover to work with the hardware I bought so it doesnt go to waste

Thanks for tip @dkemxr. I am going to do some more reading in the wiki and hopefully I can find a way to make obstacle avoidance work with the realsense camera