Missing file menu, can't get into advanced mode

I’m trying to use apmplanner2 after a long hiatus. Running on Kubuntu 14.04. Upgraded to 2.0.18. Need to be in advanced mode to add a UDP connection. Sounds like you go to “file” in order to get into advanced mode, but I don’t have “file” on the screen anywhere. Is there an easy way to get “file” back?

Have you tried Ctrl+M?

It’s in the Menu Bar at the top of the screen. It’s not in the toolbar.

Ctrl + M doesn’t do anything. Is it supposed to?

Bill, did you look at my screenshot? There is no menu bar. I think it might have disappeared in a recent upgrade.

Please walk me through the steps of how to get into advanced mode.

I’d suggest reading through this viewtopic.php?f=82&t=13420

or building from source and testing that. The release is built against 14.04 Qt5.2.1

I don’t know why kubuntu 14.04 is not working (not working, means not showing the system menu bar). Xubuntu 15.04, Linux Mint 17.1 (x86), Ubuntu Mate 15.04 and Raspbian Wheezy and Jessie are all showing the system menu bar.

I should look at building a proper ppa release for Linux, that would fix the less than binary compatible updates to Qt libs at times. Source Compatibility is much better.


Is the menu bar missing on other apps?

@Carpy I was going to ask the same, but Aaron is long term ardupilot chap, I’m sure he checked that. I didn’t notice the name this morning as I was pre-coffee :wink:

Bill, I just built it from source and still have no menu bar.

Carpy, I haven’t noticed it in any other apps but haven’t tested extensively. Others have posted online about QT menubars disappearing on KDE before so this is not necessarily an issue exclusive to apm planner.

Would you like any debugging info?

Thanks for the reminder about coffee, made me realize I am also pre-coffee!

What Qt version are you using? Type qmake -v

aaron@thunkpad2:~$ qmake -v
QMake version 3.0
Using Qt version 5.2.1 in /usr/lib/x86_64-linux-gnu

Right, pretty easy to insult someone when you are not even trying. :slight_smile: Good thing I’m in IT and not customer support…

No worries, Carpy. It was a reasonable question.

Mmmm… Strange. That binary should work as is, I’ll need to investigate when I’m back near a computer. In the meantime, have you turned it off and on again? Is it plugged in [emoji12] :wink:

I got a VM running Kubuntu 14.04.1–looks fine. Then I updated to 14.04.3–looks fine too. Now I don’t know what to do–I was kinda hoping the menu bar would go missing.

I was trying to test in a VM yesterday, but I could not get the VM to work. I’ll maybe try again today, but it does look (as somewhat expected) that something in the system Aaron is using has somehow got out of whack.

@foobarbecue does this info lead you anywhere? forum.kde.org/viewtopic.php?f=66&t=109594 :question:

Fixed it with:

apt-get remove appmenu-qt5

I think it is probably the same as that KDE issue you posted, thanks. This is what led me to it: qtcentre.org/threads/48864-M … isappeared

Now I have more menus in programs than I ever thought existed! Thanks for putting so much time into this when it didn’t have much to do with apmplanner after all.