Missing "DO_LAND_START" Command

Hi All

I recently update pixhawk to V 1.3.41 and it has been working quite well only until few days ago when I found out that trying to add “DO_LAND_START” command was not possible as the command disappeared from the list. There is an “UNKNOWN” command at the bottom of he list which I guess is a corrupted “DO_LAND _START” if you like. So, anyway I tried completely uninstalling MP including deleting the MP folder located in My Documents. Re-installation did no resolve the issues, any ideas? Thanks all in advance.


1 Like

please connect to the plane, the flight planner list will update itself at that point.

Thanks Michael for your very quick response.
I will try that shortly

I confirm it worked, thanks!


I have the same problems. It works only when connected to the plane. When the plane is not connected, I get the “unknown” command again. I would like to have the command DO_LAND_START all the time not only when the plane is on. There is a way to add command?

On the previous laptop I had once I connected the plane for the first time all the commands stay even when the plane was turn off. For example, before it will ask the pitch of the takeoff and now it does not. Is there a way to tell the Mission Planner I want the commands as a plane?

1 Like

Hi, I have the same problem, Mission Planner always starts in Copter mode (do_land_start and other airplane specific commands do not appear). In previous versions of MP, when you connected the plane, Mission Planner would change to Plane mode forever, is there any way to make it always set to Plane mode? It would be very useful for those of us who have only airplanes. Thanks!

I found a solution here in the forum, it is not the most elegant, but it works.

I think that a button in the UI that allows to switch between Copter and Plane modes would be better, I say that as a suggestion!
Thank you.

1 Like

Addendum: I found if the simulator is connected also solves the issue. In case someone is still facing this until today.