MinimOSD - Waiting for Mavlink heartbeat

Hey i know that there is another Post that was solved, but i have the same problem.
enabling the MinimOSD in the MP does not work for me. USB connected to the Board and Computer,MinimOSD 5V side is connected to the Telemetric Board of the APM. 12V side connected to the Camera and Transmitter Unit.
The screen is stuck on "waiting for MAVLink heartbeat"
I have the newest Firmware for the APM board and i’m running the 2.0 Version for the MinimOSD. Also tried the 2.2 beta version, no luck
I’m Flying a X- Quadcopter

Any help would be great
Thank you

I had similar problem, but I solved it easily :

  1. power up pixhawk with main battery and OSD connected, wait until pixhawk has blue light

  2. power up analog side of OSD (gimbal, camera, video transmitter) with second battery (3S)

  3. normally now you should have signal from OSD as a layer on your screen/googles

If you change the power up scheme in opposite direction, you get stuck with No mavlink data message. If you still see this message even after you have done the correct power up setup order, disconnect everything and wait for 5min to cool down everything. After the OSD board is cool again, start the power sequence again. This simple solution worked for me.

I have the same issue ,
I have an OSD connected up and all im getting is the waiting for mavlink message, the camera picture is also scrolling.
have tried powering up separately as suggested but no joy
any help would be great

separate issue with another OSD , was working showing everything but , then is stopped all together i.e. no onscreen messages at all

Same issue here. Video works fine. Telemetry back to APM Planner also good. I just don’t have any Overlay on my monitor. Stuck on the same thing “waiting for Mavlink heartbeats”, strangely the Firmware version states it’s V1.0…I’m sure it was a newer version than that. I’m running a 3DR X8 2014. with Minimosd V1.1. It has previously worked fine but not sure if that was the case since upgrading to APM 3.2.1

Help!!! I really don’t have a clue.