MinimOSD - Waiting for Mavlink heartbeat

Dear all,

I’m new on this forum and with my APM2.6 (Copter)

I tried to get the Minim OSD working, but after booting up it keeps showing the message “Waiting for Mavlink heartbeat”.

I used the APM-Config-OSD-Use OSD button in the APM-planner.
I also tried changing some SR1_* parameters according to info I found on the APM/OSD website
I did upgrade to the 2.0 version for the OSD
And did upgrade the charset.

I understand that I have to do something to have the APM send information the the OSD. I also understand that in order to safe the cpu, in the copter-programme the telemetry option is off.

But I can’t really find any other option about what to do next.

Many thanks for your response.

Hi Eelco,

Enable the telemetry in mission planner, initial setup, optional hardware, osd.

Thx. I did, but clicking this button in Mission Planner did no seem to do anything.

I thought I did it right, but probably not, because now it works.
Great :slight_smile:

Hey i know that Post is solved, but i have the same problem.
enabling the MinimOSD in the MP does not work for me. USB connected to the Board and Computer,MinimOSD 5V side is connected to the Telemetric Board of the APM. 12V side connected to the Camera and Transmitter Unit.
The screen is stuck on "waiting for MAVLink heartbeat"
I have the newest Firmware for the APM board and i’m running the 2.0 Version for the MinimOSD. Also tried the 2.2 beta version, no luck
I’m Flying a X- Quadcopter

Any help would be great
Thank you

Hi TheColonel,

With the APM the USB and the Telemetry shares the same port, you can’t use them at the same time, so disconnect your USB cable and power the APM with the power module.

Are you using a Y cable to connect the minimOSD? if so try to establish telemetry connection first.

I do know that that the Ports are beeing shared and i never used it at the same time so i dont think that was the issue.
I do use a Y cable to connect it but it didn’t not work.

How do i establish a telemetry connection? With the Button Enalbe telemetry in the MP? Becuse i did clicked that button serveral times.
Is there any way i see a result by clicking on it? maybe a Pop up or something?

thank you in advance


I had the same message… until I realized I forgot to cross Rx-Tx on the cable

[color=#FF0000]Tx[/color] from Ardupilot must be connected with [color=#FF0000]Rx[/color]from radio module
[color=#FF0000]Rx[/color]from Ardupilot must be connected with [color=#FF0000]Tx[/color]from radio module

Then of course everything can communicate normally

If you use a HUD, connect it as the radio module

Kind regards


I had the same message… until I realized I forgot to cross Rx-Tx on the cable

Tx from Ardupilot must be connected with Rxfrom radio module
Rxfrom Ardupilot must be connected with Txfrom radio module[/quote]

Thank You!