MinimOSD not displaying or fails to boot

I have a 3dr APM 2.5 loaded with ArduCopter 3.1.5 Quad (a TBS Discovery).
This has worked fine using the 433Mhz Radio telemetry link.
I have just replaced the 433Mhz radio with the MinimOSD v1.1
However it does not overlay any information on the video.
I am unsure if it is simply not booting or simply overlaying with no information.
I have loaded the MinimOSD with the MinimOSD Extra Copter 2.2 firmware and configured it all with ArduCAM OSD config
I am running Mission Planner 1.3.9 build 1.1.5346.13591

I have found that if I power the APM with the USB lead connected to the computer, the MinimOSD does show the boot screen over the video and if I disconnect the USB, it continues on and shows all information correctly. But if I power up without the USB lead connected…nothing.
I have double checked all wiring (4 wires from APM telem port running to the MinimOSD) and orientation of the 6 pin plug.
I have also clicked the “Enable Telemetry” button to no avail.

I have a video demonstrating the issue here =>

Any help would be appreciated.


Just an amendment to the above query…

I have wired the entire copter almost identical to the TBS Discovery diagram in this article=>

The only exceptions being
a) I have not added a BEC, the APM is already powered through the PowerModule (current sensor).
b) I have not attached the telemetry radio (I have a 915Mhz unit) as I don’t need it when flying FPV.

If I replace the MinimOSD with the telemetry radio and connect via Mission Planner on the PC, I do receive all of the telemetry data and the Artificial Horizon works as expected in Mission Planner.


It doesn’t look like anyone is listening to these posts, but i’ll keep posting my test results anyway.

I am currently on day 3 of diagnosis with this minimOSD and I’ve found that if I power the APM side of the minimOSD board first (via the APM) and then power the Vtx side of the minimOSD board second, I get good and valid OSD.

This is NOT a very good solution as it means I have to install a switch on the Vtx side of the board and turn it on after I have powered everything else.

I really hope someone has a better idea??


I have made two test flights today.
Among a swag of other issues, the minimOSD just freezes up as soon as the motors are armed.

I have example videos here … _dey69u6Ww
and here … _dey69u6Ww

Does anyone have any ideas?

Sorry no one has posted a fix. I just had this happen to me. I have not tried using the USB connection to the computer as you did in your video yet… will let you know. If you have found the fix, please let me know. My OSD was working just 2 days ago and all I did was switch from using my Gopro to a dedicated FPV camera. No software changes made, just switched cameras. If I switch back to the gopro, it still does not work, just get the MinimOSD logo across the screen.

[quote=“abear”]I have made two test flights today.
Among a swag of other issues, the minimOSD just freezes up as soon as the motors are armed.

I used to have the exact same problem. I resolved it by powering the minim from it’s own ubec and not the apm.

Run the single rx/tx wire from the minim to apm, run 5v positive and negative from minim to the ubec, solder the 2 pads on the minim and finally connect only the video signal and ground from the camera to the vtx through the minim (obviously you still need to power the camera but don’t put the camera power through the minim).

Solved my problem immediately.

Same here, I powered it with a 5v UBEC and solved the same issue…