MinimOSD "No Mav Data!"

Hi All,

I am really hoping you guys can help. I have searched lots of forums and tried lots of things, hoping you guys can suggest more things i’m possibly missing

I have a minimOSD (doesnt day version number on the board), I have flashed with MinimOSD-Extra_Plane_Pre-release_2.4_r719.hex and MinimOSD_2.4.mcm as the character set and I get the No Mav Data! error. I havce tried on a different with the same error. I have tried all MinimOSD 2.1, 2.2 & 2.3 also with the same error. I have also tried MWOSD which doesn’t show any data at all on the screen.

On each of the OSD firmwares, I am able to read back the info via the FTDI adaptor in my PC so it appears the write has been successful and loads in its respective GUI

I am using a splitter lead from the APM as I intend to use a 3DR radio in the future, i’ve tried with the standard 3 cables (ground, +5v & RX), I have taken the TX from the 3DR radio plug and connected that to see if it needed 4 cables. I have also swapped TX and RX round as this was suggested when searching the internet.

I have also update mission planned with the settings highlighted here and it still does the same.

I am now thinking maybe its a faulty MinimOSD possibly

Anyway, sorry for the long winded issue and thanks in advance for you help :slight_smile:

Hey Bro,

Did you solve your problem?
I’m having the same problem, but no warning. I just have no data coming from the APM.

I am going to try looking at the settings, in the link you have on your post, to see if that is my problem first.

I have telemetry data coming through, and I can change parameters, and connect no problem, but no OSD data. I am going to check the cable, again, or just make another.
How did you connect your RX cable on your OSD? Did you splice it into the TX line from you APM? I would assume this is the correct way.

Hi, yes I solved my problem. Turned out the telemetry cable I bought from ebay has the ground wire (black one) to BLK on the MinimOSD rather than ground.