Servers by jDrones

Minim OSD V2.0 connection to PC via FTDI

I bought the OSD from following vendor :
http://www.goodluckbuy.com/crius-mavlink-osd-v2-0-minimosd-compatible-atmega328p-microcontroller-dc-dc-voltage-stabilization.html

Had problem connecting the OSD v2.0 to PC via FTDI cable. I supplied 5V to the FTDI connector and 12V to video side. After connecting to PC, the PC can recognize the OSD at the COM port, but after clicking READ in the configuration tool, the error message says “FAILED TO TALK TO BOOTLOADER”, though I pressed the RESET button, it did not help.

I have had 6-7 Minim OSD V1.0 and enough experience to configure V1.0, but this is the first time I try V2.0. The OSD board works fine when connected to APM (with default setting shown on monitor).

Pls advise what did I miss?

You don’t need 12V t program it via the FTDI, just the 5v is my understanding. At least that’s the way mine works.

Just from my personal experience connecting stuff to these usb-serial devices:

Try a different cable…some of them just dont work.

My first guess is check your baudrate in windows…make sure your com port matches the minimosd which I believe is 57600 by default on the minimosd and the flash program.

Make sure you crossover RX and TX between FTDI and minimosd. Baudrate-8-N-1.

I believe I had to connect DTR on the minimosd. I think it’s the pin labeled ‘green’ on its pinout.

Just for general knowledge since it sounds like you’ve used them…Some breakouts have the wrong TX and RX on the header and need the ones labeled TxD and RxD.

I’ve also found USB hubs to be problematic.

That’s just my experience.

2-3 years ago when I first ordered OSD from China, you need to supply 12
volts at the video side to work. After some time, I put solder on 2
locations on the OSD board, so only 5 V is needed to supply both sides. But
in the last year, when I ordered 3-4 OSDs also from China, the boards
were soldered so only 5 V is needed. All the above refer to V1.0.

But the one I have problem is V2.0 which is from Goodluckbuy. If you refer
to the description, it clearly says 12V and 5V are both needed unless you
do modification.

Hi Lance,

Tks for your help. I tried following , but made no difference :–

  1. Tried another cable.(which proved to be working in another situation)
  2. Default baudrate is 9600. But I tried changing it to 57600, still not
    working. Also confirm baudrate -8-N-1
  3. I did crossover Rx and Tx, and also exchanged the Rx and Tx connection,
    assuming the header labelling from the manufacturer is wrong, but did not
    help either.
  4. I do not use USB hub.

By the way, where do you connect the “DTR green pinout” to ?

All the things you suggested and I tried to trouble are quite
exhaustive.Hands up.

Anyway, tks for help.

Frankie

did you find the solution?

Servers by jDrones