Mini Pix Not flashing

Good day

I recently purchased the Mini pix flight controller from radiolink. I cannot flash firmware onto it for some reason. Initially mission planner recognized the com port but I kept getting errors upon flashing. I used the Zadig software to flash new drivers, but now mission planner does not recognize the com port.

On top of that, when I initially plug in the Mini pix via USB, the LED on it flashes red and blue, then after some time it flashes green and yellow.

May anyone please please help me flash the firmware onto the Mini pix. Thank you for your help

Did you flash the -arducopter_with_bl.hex - file first? > for ChiBios
Can´t remenber if I did this with Betaflight configurator or MissionPlanner and custom firmware select with a locally stored file. Just try.
My Mini is now running the heli firmware 4.02 without issues.

Hi, thanks for replying.

I went to this site:

but I can’t download the hex file. When I click it it just opens a page instead of downloading it. So I copied the contents of that page into a text file and converted it into a hex. I tried flashing that onto the mini pix and I got an error about not finding a string somewhere. Do you have any ideas on how to go about this?

Thanks for the help

Right click, Save As. But I would think you can just download the .apj file and use Mission Planner’s “load custom firmware” button.

I tried both. When trying to flash the hex file, I get this error:

and when trying to flash the .apj file, I get this error:

Do I need to be in Bootloader mode first before flashing anything?

Sorry, that’s the extent of my knowledge on those FC’s. If you treat it like an F4 or F7 board, which I am familiar with, you would boot into DFU mode then use Betaflight to flash the bl.hex file as René stated.

To get around fiddling on the board to get into DFU mode, you can try to start this with the MP , but instead of flashing the custom firmware with it, start the Betaflight configurator. You might close the MP to grant access to Betaflight for flashing. As long as you don´t disconnect the usb port, the controller should stay in DFU mode. Then select your locally stored file and flash.
As I already mentioned, I did it only once and forgot how I did it exactly, but it should work as described.

What do you mean start this with the MP? Do you mean forcing the board into bootloader mode using MP then using Betaflight to flash the hex file?

Thanks for all the help. I really appreciate it

Yes,start the DFU mode with MP. and then continue with Betaflight.

Edit : If windows does not report the dfu mode correctly to Betaflight, you must use Zadig and select STM32 Bootloader.

hmmm seems like it should work. I go on MP and click force bootloader and it says that works. But on Betaflight it does not enter DFU mode, and I can’t connect, so I cannot go onto the CLI and force DFU mode from betaflight. Getting very confused now

Read my edit…use Zadig.
The controller must stay unconnected all the time.

EDIT: Did close MP before you started Betaflight?
Just go to the firmware flasher, no CLI.

If no success, read here,!-Radiolink-Mini-PIX-F4-Fc
I think vierfuffzig explained it there.

Edit: This is about ChibiOS and on page one all steps are explained.

Does this work? All Options menu.

I think he has to read first and will succeed…

Hello, sorry for the late reply, have been busy. I have tried your suggestions yet Betaflight still does not recognize the board. Here is my step by step process:

  1. Plug in the board normally, open Mission planner and force board into bootloader mode
  2. Close Mission Planner
  3. Open zadig, and list all devices. I am looking for STM32 bootloader right?
  4. STM32 bootloader does not appear, what shows is a device called mini-pix. I use this device
  5. Install WinUSB driver onto minipix. I also tried with Ibusb driver using these same steps
  6. Open Betaflight, check for DFU mode. I get nothing, there is no device shown on betaflight, so how can I flash the firmware?

Thanks for all the help. Sorry for all the questions, I am a beginner looking to get this working

I am sorry to hear this. Your procedure was quite right, but be a little more adventurous.
The problem seems be, that windows reported a different driver ( on my test today it was Pix4 Flow…) and not the standart STM32 Bootloader. ( I have this new bootloader on it )

You can try first MP, maybe the app is now capable to do this. Both ports are listed and it loads the HEX file.

If this does not work,we must pay more attention on the Betaflight flasher
Did you use manual selection on the Betaflight Configurator and entered DFU on the left?

If nothing works, we have a least the hardware option…here

Ok well now MP not even recognizing the com port, highly considering just moving to the omnibus I have laying around

Well, the reason might be more based on the stuff from Redmont…after my short test yesterday, I was no longer able to connect via bluetooth anymore and these are different devices. My phone and QC did…:face_with_raised_eyebrow:
Anyway, take the Omnibus for this procedure, its more easy because of the hardware boot switch and get into it. Then give the Mini Pix a second try.

BTW… what version is your Mini, V1 or V2?