Servers by jDrones

Mini osd overlay disappear?


(basti) #21

@xingxing the character issue after flashing MWOSD is likely due to a charset mismatch, as MWOSD and minimOSD charsets are not interchangeable. make sure you’re using the right *.mcm file required for the respective firmware.
in case you want to go back to minimOSD fw, you’ll likely need to clear eeprom first. a respective sketch can be found in the minimOSD repo’s tools folder iirc.

cheers, basti.


(xingxing) #22

Can I reset the eeprom in the mini osd config tool. I reset the eeprom in the config tool, but the issue still exists.

—Original—


(RickyG) #23

did you first try flashing with the correct character set.


(xingxing) #24

NO,I think I have flash the character set but not sure the font is match with the Firmware. can you send me your Firmware with the right character set?my email:304676018@qq.com. I just plug in the wrong line that cause short circuit, but the osd seems still ok, l don’t know how to flash back to mini osd FW right now. besides do you know how to check the osd whether it’s good or not. according to MWOSD manual, I can flash debug Firmware, but it can not be flashed any other Firmware, I didn’t know how to check the osd in debug mode. the manual ask to check the value of PKT and RX value. I didn’t know what’s that mean.

—Original—


(xingxing) #25

the flashing stop , any advice?thank you.

—Original—


(RickyG) #26

Here is a link to the files


(cala2) #27

Thats updated Ricky?


(RickyG) #28

It’s what I had. There may be newer…but I was asked for what I was using.

So is MWOSD Arudcopter compatible.


(cala2) #29

Im using this one, I hope the most update. https://www.rcgroups.com/forums/showthread.php?2591835-New-MinimOSD-fork


(RickyG) #30

Thanks I have an OSD I need to flash.

cheers


(cala2) #31

You have more functions and more screens here, new modes are included too.


(xingxing) #32

thanks cala,i fix the problem eventually,the step blew :slight_smile:

  1. https://www.rcgroups.com/forums/showthread.php?2591835-New-MinimOSD-fork;downlad and flash the latest mini osd firmware according to the link.
    2.ref to mini osd extra wiki :https://github.com/night-ghost/minimosd-extra/wiki/APM set the folowing parameter:
    SERIAL1_BAUD, 57 (telemetry output at 57600)

SR1_EXT_STAT, 2 ( 2hz for waypoints, GPS raw, fence data, current waypoint, etc)

SR1_EXTRA1, 5 ( 5hz for attitude and simulation state)

SR1_EXTRA2, 10 ( 10hz for VFR_Hud data )

SR1_EXTRA3, 3 ( 3hz for AHRS, Hardware Status, Wind )

SR1_POSITION, 2 ( 2hz for location data )

SR1_RAW_SENS, 2 ( 2hz for raw imu sensor data )

SR1_RC_CHAN, 5 ( 5hz for radio input or radio output data )

If you fly copter than you also need to set SR0 also:

SR0_EXT_STAT, 2

SR0_EXTRA1, 5

SR0_EXTRA2, 10

SR0_EXTRA3, 3

SR0_POSITION, 2

SR0_RAW_SENS, 2

SR0_RC_CHAN, 5
3.https://github.com/night-ghost/minimosd-extra/issues/121
disable either BRD_SER1_RTSCTS or BRD_SER2_RTSCTS by setting it to 0 (or maybe both) in parameter tree ,this is very important step ,I set both to 0
and the osd works OK except the flight mode and real fight didn’t work ,I suppose it’s a bug of fimware.maybe it can’t be fix by night ghost .please find my topic in GitHub
https://github.com/night-ghost/minimosd-extra/issues/236


(Shawn) #33

Make sure you flashed the Mavlink verson and not the PX4 version too. Otherwise flightmodes dont show properly andI think some other values show as zeros.


(xingxing) #34

I have flash mavlink and px4 ,all of the version can’t show the right mode.