Servers by jDrones

Mini APM 3.1 with Neo 6M & 5883L compass, calibration problems

Mini APM v3.1 running 3.4 firmware. Ublox Neo-6M with HMC5883L compass

As many others have found I too am not able to get a complete compass cal. The image shows the pattern I get, in this instance 2911 samples:-

Compass; declination and offsets all checked, and 'APM + external compass.
Live calibration, clearly. I have persevered by running it to get over 21,00 samples: it still asks for more. Is this the way it is intended to work? How many samples is it actually looking for. Also, the popint at North and turn 90 dgrees doesn’t work.

I have this GPS/Compass:-

There is no indication of which way is forward! Does anyone know which way it should point?

On the GPS: Mission planner ‘Flight Data’ shows ‘GPS: No Fix’ and ‘Bad GPS Health’. I have none of the GPS lines on the map.
I have tried other older firmwares, but no luck.
Please, can anyone help with this???

I have found the problem with the compass. The Mini APM I bought was sold as having no onboard compass - it actually has! I only found out after taking off the case. The jumper is cut, and now I get a good quick calibration

Still no GPS fix though. I suspect it’s faulty, especially after testing it in U-center. It only weeklypicks up one or two sats.

the mini neo7 gps units for mini apm work well, i use them on my robocat.

I’ve had a look at them, they look very good. I think I must buy one.
Thank you for that George.

I now have a MINIAP GPS/Compass. This works perfectly, so the issue is resolved.

Servers by jDrones