Min_pwm output to the esc right after boot possible?

Hey guys,
i use E1200 proulsion systems. works very well with
MOT_PWM_MIN = 1120
MOT_PWM_MAX = 1920

at startup, the esc are starting to beep every x second because of “no pwm input detected”.
pixhawk is not outputting any pwm signal to the motors before you press the safety switch as i understood, than everything is good.

is there any way to output at least a minimum pwm value all the time? even when the safety switch is not set?
thanks :slight_smile:

no one? :frowning: hmmmmmmmmm

Looks like you need to disable this option

sadly that does not help.
its allready on 0 -> pwm always enabled. but this is only arm/disarm pwm.
i already need mot_min_pwm output when i start my pixhawk up. even with the safty button not pressed.

i think the only option is to disable the safty button or?

BRD_SAFETYENABLE: Enable use of safety arming switch
This controls the default state of the safety switch at startup. When set to 1 the safety switch will start in the safe state (flashing) at boot. When set to zero the safety switch will start in the unsafe state (solid) at startup. Note that if a safety switch is fitted the user can still control the safety state after startup using the switch. The safety state can also be controlled in software using a MAVLink message.

As far as I know, the only way to do what you want is to ignore the safety switch for the motor channels. One way to do this is to simply disable the safety switch with BRD_SAFETYENABLE = 0, as you have already found. Another option is BRD_SAFETY_MASK (http://ardupilot.org/copter/docs/parameters.html#brd-safety-mask-channels-to-which-ignore-the-safety-switch-state), which will allow you to define which channels will ignore the safety switch.

For a quad (channels 1-4), I think it should be BRD_SAFETY_MASK = 15
Hex (ch 1-6) is 63
Octo (ch 1-8) is 255

In either case, your motors still won’t spin until you arm the drone, but will receive a low PWM signal and stop the motor beeping. In the second case, I think you will still need to toggle the safety switch in order to arm the drone, so it is probably the safer option.

Hey Rick,

awesome hint ! thanks a lot, exactly what i needed :slight_smile: