Servers by jDrones

Maxbotix sonar 1202 and 1242

(David ) #1

Good morning /pm to all developeders, i need info for set up on mp and a stable wiring for make work the mb 1242 and 1202 on pixhawk and pixfalcon, Hope in a positive answer by all the developers

(chris rey) #2

did you read this? everything is there.

(David ) #3

I have try but when I’m setting forward sonar stop working

(ppoirier) #4

If you change orientation, the signal will be displayed in thr RADAR screen
You neeb to CTRL-F to activate proximity in Mission Planner

(David ) #5

Hi Ppoirier, i’ve wired arduini pro mini with tf lidar mini…this is the screen on MP

after this i’ve press CTRL-F and my menu is this… ,
i’ve press proximity, and in the open window i have found the pic of a quad, i’ve try move someting in front of the drone but i cannot see nothing

(ppoirier) #6

The maxbotix ( That seems to work fine) has to be set to look forward in the parameters

(David ) #7

sorry what i’ve written before is about tf mini lidar on arduino,
the sonar is 2.55 stable…even im moving a little beat still the same

(David ) #8

also for maxbotix i need to wire it on arduino???

(David ) #9

Hi, its normal that the measure of the sensor is still the same?
I’ve done the arduino with tf mini lidar configured with your ino library

(gmorph) #10

David have you resolved the issue.

Note at the moment ArduPilot only supports one Maxbotix I2C sonar as they all use the same hardware address and we only have that single address hardcoded at the moment.

Thanks, Grant.

(ppoirier) #11

@Dave84 Sorry I did not see you last request. I suggest you put my name when you reply (do a @ and you will see names). If you have questions about the TFMINI and Arduino I2C please ask here: How to make the TFMINI rangefinder talk I2C

(David ) #12

Hi, im testing now lidar lite v3… for now i wire and set it on i2c port but i need to test it also on pwm,
i can see that on i2c work… but i don’t now if on pwm will work better

(ppoirier) #13

I never tried, just used it on i2c

(David ) #14

i must check why when im setting front the sensor stop work but when i set it down work again

(ppoirier) #15

I explained this a few weeks ago

(David ) #16

already done… but its not working

(ppoirier) #17

This is working for copter , not plane
If copter , what is the Flight Controler and Arducopter release ?

(David ) #18

flight controller is pixfalcon and the version of the firmware is 3.5.5