MAVSerial pass to GPS


I’m trying to configure a UBlox M8N using MAVSerial Pass and ucenter but the MAVSerial Pass button does not seem to do anything and the ucenter cannot connect on tcp://localhost:500

I’m following these instructions:

Any ideas would be gratefully received.

ArduPlane 3.7.1
Mission Planner 1.3.45
ucenter 8.24


I experienced the same problem using Mission Planner 1.3.45 on Windows 10.
Clicking on MAVSerial pass doesn’t seem to do anything and U-Center (8.25) refuses connection to tcp://local host:500 (or tcp://
I searched with net stat -a in the command line and there is no open port on local host or
Is there any other things to try in order to troubleshoot why MAVSerial pass is not working?

Hi Miguel,

In the end I used the GPS_NAVFILTER instead of u-center, see

Hope that helps.


Thanks Tim,
I’m trying to make sense of your lead but I have been unable to figure out how you worked out your solution and the results you got. If you have time please provide more background.
Best regards,

Hi Miguel,

In Mission Planner, I set the GPS_NAVFILTER property to 8 (Airborne 4G) which seems to be the default anyway. I sent it up under a weather balloon to 34,000m and the GPS worked until 21,999m. The Ublox M8N receiver was on the outside of the payload so, despite the suspicious number, it probably froze. It was about -52C at that altitude.

The net payload will have two GPS units, a Here+ and another M8N, both set to Airborne 4G, both insulated to hold them at about 30C.

Not sure if that helps but it’s all I did.


I think this is not the solution we need… Is there a way to connect the U-Center thru Mission Planner to update the GPS firmware? Please explain how. Thank you

Hi, Im having the same issue right now, With a Kakute F7 running ArduCopter 4.0.6
The GPS module is a NZ-GPS, Which shows fine on U-Center when connected with a USB to Serial board, FTDI. But doesn’t/couldn’t works with the tcp://localhost:500.
My mission planner also says, No GPS. while I know it is plugged in right. (I have tried other UARTs and reversing the wiring too)

Any idea what could be the possible reason(s).