Mavros is not publishing any data

hello y’all, I am running ROS with sitl and launching apm.launch script with sitl fcu_url as udp id, its working fine and I am getting the results and data on mavros/local_position/odom topic. But as soon as I change the fcu_url as /dev/ttyACM0 for hardware testing, I am getting no data over that topic ? what might issue here? I appreciate the help or suggestion. thanks!

did you request some stream rate ?

No I didn’t. I have followed instructions on the website and everything worked fine on SITL instance.
this one:

Found similar issue here Unable to echo different MAVROS topics - ROS Answers: Open Source Q&A Forum No answer

I have just tried out set_Stream_rate and /mavros/imu/data is showing data which was not streaming data before. another thing is i am doing indoor testing. and the GPS fix is 0.

Is is something to do with GPS fix or so? I am talking about /mavros/local_position/pose topic which is not streaming data.

Yes, it needs GPS fix to stream that data.

1 Like

yes, the issue is resolved. thank you very much.

@Captain299792458 , Could you mention the solution for this problem ? I’m having same issue and cannot get the /mavros/local_position/pose data. There is no data on /mavros/imu/data as well. but /mavros/state is being publihsed.
I have created a ticket here about the same