MAVProxy to MAVProxy [SOLVED]

I Would like to establish a MAVProxy to MAVProxy connection.

My Setup, all in same Network:
#1, RasPi with Ardupilot ( SYSID_THISMAV=1) and MAVProxy (
#2, Linux PC with QGC and MAVProxy (

What works:

  • Communication MAVProxy RasPi (#1) to Ardupilot
  • Communication QGC (#2) to MAVProxy RasPi (#1)

What not work:

  • Communication MAVProxy (#2) to MAVProxy (#1)

MAVProxy output #2:
Waiting for heartbeat from
MAV> link 1 down

How I start MAVProxy:
#1, --master=/dev/ttyACM0,115200 --out=udp:
#2, --master=udpout: --target-system=1

I suppose I don’t get the routing part of MAVlink. Because QGC can connect.

Any hints how to get it work?

Thanks, Sebastian. :slight_smile:

What’s this IP address? It wasn’t described in your setup.

For #2, you’ll need: --master=udpout: --target-system=1

Hello Stephen,

thanks for your reply.

I messed up the IP addresses here in my post, corrected it (replaced .109 by .99).
In my terminal I used the correct IPs.

Same result.

Ahh ok. Try udpin instead with the PC IP address, so: --master=udpin: --target-system=1

That works, many Thanks!!