Mavproxy through Wireless LX40 Modems

Hi !

I am stuck with a little network issue. I am trying to use 2 Sierra wireless Airlink LX40 modems to communicate with my drone.

For this I made a few trials. First I took 2 computers, the first one is on fix IP and the second one on fix IP I link them with a simple RJ45. On the first one i use SITL to simulate a vehicle with the command --no-mavproxy. I then launch mavproxy with the command --out udpbcast: Then I open Mission Planner on the second computer and I am able to connect and operate the vehicle on UDP 14555.

Now I want to use the Sierra wireless Airlink LX40 modems for my communication so I plug to each computer a modem. I configured them to be on I am able to configure them to forward udp and tcp ports.

This modems have a second IP adress, and which are the adress that we will call when we want to talk with the other computer. So for instance if I have a camera that is plugged on the computer linked to the modem, I define a port (lets say port 80) on this modem that relays the adress on port 80 of So if I want to access the camera on second computer, I have to call

I linked both modems and am able to ping both modems. Now when I launch mavproxy with my udpbcast: I don’t know which udp port I should forward so that my second computer has the control of my simulated drone. I tried multiple option but MP were never able to connect to the drone.

I also tried to disable port forwarding, and enabling DMZ with no success eather :

If you have any suggestions, I would love to hear your advices.