Mavproxy + mission planner + dronekit with no companion computer

hi there, i made a post about this a while ago but it was not clear enough, so i’m sorry for the double post.

i’m trying to connect mavproxy, mission planner and dronekit to my hexa.
i am not using a companion computer my setup is as follows:
i have a pc running windows for mission planner and on that same pc im running a virtual machine with ubuntu 16.04 running dronekit and mavproxy.

first i’m running mavproxy and forking out 2 connections, 1 for mission planner and one for dronekit with the following code: --master=/dev/ttyUSB0(im telling mavproxy to use the serial which the telemetry dongle is connected to) --baudrate=57600 --out= adress on my virtual ubuntu) --out= (ip for my windows machine). i am able to connect to the drone in mission planner via the udp at port 14550. and i am able to send commands via mavproxy console such as change modes/arm etc.

my problem is when i execute my connect script from dronekit to connect to the drone im getting a timeout error.
the code:

from dronekit import connect, VehicleMode, LocationGlobalRelative
import time
import argparse

parser = argparse.ArgumentParser(description = ‘commands’)
args =parser.parse_args()

connection_string = args.connect
vehicle = connect(connection_string ,wait_ready=True)

when i open a new terminal i run the command to launch and connect drone kit : python --connect
once i run this it gets stuck and after 30 seconds i get the following output:

dronekit.TimeoutError: wait_ready experienced a timeout after 30 seconds.

sometimes i get the following output:
gcs failsafe cleared

and then it gets stuck and after 30 seconds:

dronekit.APIException: Timeout in initializing connection.

i searched for about 3 days for solutions and tried everything that is out there pretty much, such as telling dronekit to wait longer than 30 seconds, but still i get the same error.
i updated dronekit to latest version updated pymavlink and pyserial. also downgraded them to check if it will solve this but nothing works.

my main question is: is this error happening because dronekit can only run on a companion computer? and is not built for connecting threw telemetry radio?
if not, what am i doing wrong?

i sincerely am lost and praying that someone can help me.
thanks in advanced. i would literally pay someone for a solution.

and again, sorry for the double post.

While I don’t have a solution to your timeouts, I can tell you that:
a) I run dronekit on a raspberry pi as my telemetry ground station, no companion computer in the air.
b) I run dronekit via an xbee telemetry connection without issues. My dronekit ground station connects, arms, receives telemetry data, and then disarms upon landing. Nothing fancy, no in flight commands, etc. I use a Futaba TX for flight control while in the air.
c) AFAIK, recently it was decided to not spend any time or funds on updating and maintaining dronekit. I could have missed a change in that status, though.

Hope this helps by at least letting you know that you are not wasting your time, it can work as you wish, but will need to be tweaked some.


@llamatrails thank you very much for your reply!

is the dronekit still being upgraded even? i mean is it still being developed or all support has stopeed?

Check to back topics. As I recall, the issue of funding came up, it was basically voted down. Pity, but the community spoke.


I see, by the way, I solved my connection timeout error. My problem was that my cheap radio telemetry dongle has a very very low bandwidth, I changed to a powerful one and everything is fine.