Servers by jDrones

MavProxy communications with dronekit-SITL

With MavProxy running on a Pi and dronekit-SITL running on a UBUNTU (intel) computer I am able to connect but not change mode or set parameters. Sometime back there was a problem associated with the version of pymavlink. Is there a particular version of pymavlink that I should be running on the Pi? When I connect with the PX4 flight controller, MavProxy can change mode and set parameters.

You should be using ArduCopter 4.0.7-rc1 and the latest available MavProxy. They work great together!

I do not know about you, but I compile my SITL. And it`s version is 4.0.7-rc1

so my SITL behaves like my vehicle.

Where are you getting your outdated SITL from?

Servers by jDrones