MAVProxy cannot act as ground station for heli/Copter but works fine for Plane (Solved)

I tried to use MAVProxy as ground station. It works great for ArduPlane. However it does not work for heli/quads. I can see the flight mode and the no of packets received in the console. But that is it. No other information ( GPS/Altitide, etc… ) is not shown. I was wondering if I am the only one who is having this issue or other are also facing this issue.How can I get this fixed? I tried this with and older version and latest ( 1.5.7) of MAVProxy. Both have this issue. I tried passing the option –quadcopter and –dialect=autoquad but no luck. I can run Copter in SITL, so this indicates that MAVProxy can infact handle Copter. However it does not work when I try to use it as ground station.

what ArduCopter firmware version are you using?

I am using 3.3.3 ( HELI and Quadcopter). Both do no work.

I just tried 3.4.3 ( Heli) and it works fine. So it appears that the latest version has fixed the problem. Yay!!