Mavlink connection between Mission Planner and APM 2.6

Hello everyone,

I am a complete newbie to Arduino, programming, quadrocopters, this forum etc. but I received my APM 2.6 (external compass), uBlox GPS with Compass Kit, Radio Set (Frequency: 433 Mhz), APM Power Module with XT60 Connectors Kit, and MB1240 XL-MaxSonar-EZ4 High Performance Ultrasonic Range Finder from 3D Robotics a few days ago. I plan to use these for a quadrocopter project.
I haven’t built this kit into a frame yet but I have connected the peripherals to the APM 2.6 and have blutacked them into position in a shoe box lid for the moment (I’ll explain this bit later).

I am using a Windows 7 32 bit laptop, I’ve made sure that the COM Port and Baud Rate are assigned correctly (COM10 and 115200, respectively) and I’ve made sure that I am using the latest Mission Planner and AMP Planner software (1.2.94 build 1.1.5147.31144 and v2.0.0 [RC3], respectively). I also correctly installed the device driver software, manually, for the APM 2.6 so that it appears under the COM/Ports section in my Device Manager Suite.

During Initial Setup, the firmware installed from Mission Planner to my APM 2.6 no problem. I managed to get the Mavlink connection to work earlier but then the software wanted to calibrate the sensors on the APM 2.6.
At this point, I only had the peripherals connected to the APM 2.6 and I didn’t have anything to keep everything level and in the correct position for calibration. So I used Blutack and a shoe box lid to keep the components in a fixed position relative to each other, which would allow me to tilt the APM 2.6 on its side when told to do so by the calibration section.

Unfortunately, I had accidentally pressed a button on my keyboard so the calibration section of Mavlink had moved on past a few APM 2.6 calibration orientation requests and I wanted to go back just those steps but the software’s ‘Back’ button took me all the way back to — and restarted — the Mavlink connection process.

This attempt failed after it got stuck on ‘Got param RTL_LOIT_TIME’. I clicked on ‘Cancel’ and, in the same Mavlink window, received a message along the lines of ‘only one heartbeat received’. I clicked ‘Close’ and tried to reconnect, using the button in the top right hand corner of Mission Planner. This produced a message saying ‘no heartbeat packets received’ so I closed that window and clicked on the Wizard in Initial Setup and the same problem with the Mavlink connection getting stuck on ‘Got param RTL_LOIT_TIME’ occurred. It occurred again after I’d tried reinstalling the firmware first! This problem has occurred every time since, when I have tried to reconnect, even if I reset the APM 2.6 using its reset button and/or took the USB cable out of my laptop and reconnected that before running the Mavlink connection process.

I tried to sort this by uninstalling and reinstalling the device driver, Mission Planner and AMP Planner software but to no avail; the getting-stuck-on-‘Got param RTL_LOIT_TIME’-problem still occurs.

I don’t know what to do and haven’t been able to find the solution online. It’s exasperating because I had it working earlier! :frowning:

I really hope one of you kind people can help me get this working again.

Thanks in advance for reading,

try getting into terminal, and do a “setup” > "reset"
and see if that helps

Hello Meee1, thanks for replying!

I had already tried that (forgot to mention that I’d tried going to Terminal and entering ‘Erase’, followed by ‘Setup’) and it didn’t work either.

However, I tried it on another laptop where it worked…until that laptop crashed on me (it’s old to be fair) so I then tried it on my laptop again and it worked! Thank goodness! I’ve calibrated everything but the sonar and the radio, and I’m now changing some of the parameters :slight_smile:

So pleased to have this up and running now. Although I had an idea, which is that it would be quite helpful if there was an option to power the APM and its peripherals by USB cable but to communicate with it via the radio so that you could set that up at the same time as having both units plugged into the laptop via USB. The reason is that I don’t have a battery yet so I can’t power the APM independently of my laptop and you can’t connect, and communicate with, the radio telemetry if the APM’s plugged in by USB as well :S When you connect a BlackBerry to a computer via USB, you get the option to ‘Charge Only’, use it as a ‘USB Drive’ or ‘Sync Media’ so maybe a similar sort of system could be introduced?