MavFTP & Arduplane 4.1.2 >> parameters do not load

Since I updated to 4.1.2, I can not connect via wifi (TCP). I have to disable MavFTP with BRD_OPTIONS=3 for it to progress. Has anything changed in the last AP version?

By USB it works correctly but not by TCP.

Version MP: 1.3.75

Hi Aticof

I am having the same issue it get stuck at MavFTP and stuck at downloading parameters and I am not able to work around it and it fails to load paramters!! please let me know if you found the way to work with it!!

There are two candidates:


The second is a genuine bugfix and if that’s the cause I can only assume that the mavftp support in MP and QGC never worked since ftp burst read generally did not work.

Hi Andy

Not sure if you could help me with this issue but it seems I have new error coming when I am trying to connect SITL with mission planner


If you have any suggestions

Thanks and Regards

Try the beta build of mission planner - might help

Unfortunately, It didnt helped either besides whenever I try to connect it I get a window with upgrade firmware 4.1.2 which is blacked out and the mission planner crashes!

I am able to connect using MP on Windows using a CubeOrange and ESP8266 telemetry radio.

In my test I used Rover-4.1.1-rc1 and MP beta build 1.3.7961.38854.

I’m not saying that there isn’t a problem of course. Just that I couldn’t immediately reproduce it with the setup listed above. Maybe we need more information on the telemetry radios being used and perhaps also some parameter, tlogs or onboard log files.

I’m also able to connect to Plane SITL.

Hi rmackay

Unfortunately, I have no log as I wasnt connected through serial port and I am not able to connect by radio telemetry!!

And now I am also not able to connect on windows

and even if I somehow connect with sitl even after arming drone its not flying!

Its surely something with Mavlink . If you could have any suggestions


I think we may need to try and divide the problem up somehow. For example:

  1. is the issue related to the PC? Maybe try multiple PCs?
  2. is it related to the AP version on the autopilot? Try reverting to an earlier version (4.0.x) using MP’s firmware install screen’s “All Options” link
  3. is it related to the telemetry radio? Try using USB vs telemetry (I think this has already been tried above but it seems the situation on your PC has perhaps changed so neither works.
  4. is it related to the specific autopilot? Maybe try another autopilot using the same version of AP and MP.
  5. is it related to the ground station software? Maybe uninstall and re-install MP or use the MP stable version. … or try QGC or MAVProxy…

Surely some combination of firmwares, autopilots and PCs will work (my setups works for example) and some setup doesn’t work. We just need to divide the problem enough times to figure out which of the variables is important.

Another shot in the dark, maybe it is the driver installed on the PC. MP has a “driver clean” option on its Ctrl-F screen that I ran recently and might help.

1 Like

@rmackay9 I will update you shortly. I am wiping out everything and reinstalling again on windows

but for the Ubuntu VM I am facing the same problem as mentioned on the above link with the parameters do not load and update window for 4.1.2.

I will try to keep posted for both windows and linux besides Its not working on either of them for me. Which were working before absolutely fine.

1 Like

I’d like you to give us a bit more information so we can try and reproduce, plus try a few ideas.

  • what flight controller?
  • what WiFi adapter? what firmware version on the WiFi adapter?
  • what serial port on the flight controller is the wifi adapter using?

Next, some random ideas:

  • it could be a flow control issue. Check BRD_SERn_RTSCTS parameter, where n is the SERIALn number of the uart you are using. It is likely set to 2 for auto. Try changing to zero.
  • you say you updated to 4.1.2, but you don’t say what firmware you updated from. Did you test it on 4.1.1 or 4.1.0?

Thanks for helping us track this down!

1 Like

can you look at the questions I just gave to @Aticof and give the info for your setup? It may be that we have the hardware to reproduce your setup and not the setup @Aticof has. I suspect that being able to reproduce this issue will be important and we will need to look at the uart traffic with a logic analyser

1 Like

Sorry, you’re right.
I do not use a wifi module connected directly to the FC, I connect via wifi through the Tx Dragonlink wifi module.

  • Matek F765 Wing
  • Tx Dragonlink V3 >> ESP32 Wifi Module (I don’t know FW version)
  • SERIAL1 / UART7 (on F765 for telemetry)
  • Connection TCP>> IP ADDRESS: PORT: 14550


  • BRD_SER1_RTSCTS, 1 (I use Flow control with Dragonlink)
  • I have updated from 4.1.1 to 4.1.2 >>> with 4.1.1 I had no problem


Hi @tridge

1)No, at the moment I am not connected to any flight controller
2)No WIFI module
3) I have been using the same connection TCP as @Aticof IP ADDRESS: PORT: 14550

I have been using to simulating the missions without any connections via serial port.

On windows as @rmackay9 suggested I reinstalled the mission planner and found that
when I am trying to connect mission planner with SITL

It is unable to run fetch the parameters

and even when connected to it somehow even when armed it wont takeoff [must be due to unable to load parameters]

I cant run mission planner from the simulation window as it never connects and give the following errors

I tried to see on the Mavproxy console it shows the following errors

Preflight storage failed should not be the case if I am not connected to the external hardware I assume!!

For linux
I am facing this issues
It tries to connect the through udp then

I see this and just after that it pushes for firmware 4.1.2 blackedout window and mission planner crashes

and the other windows look like this

Considering I have had mission planner working on both the systems before and I was able to simulate my flight plans.

considering the facts: I have everything updated to the latest versions on both ubuntu 18.04 and windows.

If you need any further information I would be happy to share.

Thanks and Regards

@rmackay9 @tridge

I found it works perfectly fine with another system seems I have been cleaning everything but still some residual files affecting it but I did removed the temporary files and local app data.

cleared the drivers its not working either…

May be it can be port issue not sure I have everything set to default

any suggestions to force resetting to default state ??

@Aticof, @Alpha2Assassin,

My understanding after talking with @tridge and @hwurzburg this morning is that the issue has been determined to be that the ESP wifi radio used did not support MAVLink2. As part of the 4.1.0 release we changed the default SERIALx_PROTOCOL parameter values from “1” (MAVLink1) to “2” (MAVLink2). This means that by default ArduPilot will try and use MAVLink2 for all telemetry radios.

The best solution is to upgrade the telemetry radio to be able to work with MAVLink2 but if that fails it may help to set SERIALx_PROTOCOL back to “1”. MAVLink2 has many good new features though like MAVFTP which makes parameter downloads much much faster.

Thanks for the report and please tell me if you think the issue isn’t resolved.

@rmackay9 Thank you so much it did work for me and fixed the issue

1 Like

@rmackay9 thanks for the study and explanation


Previously everything was working perfectly with an “esp8266” and an " Omnibus F4 Nano V6.1", but recently and after updating the mission planner and Arducopter, now the MP can’t get the parameters through TCP or UDP (the MAVlink speed is less than 50Bytes/s, and the only thing that works is when I change the " Flight Modes" on the transmitter, it changes on HUD - Nothing else!). I switched to an esp32 module, and I have the same problem!

I tried every solution that I found, but it’s not working. Any suggestions?