Mavericks and FTDI Drivers HELP!

Hey Everyone,

I’m stuck. I have the APM 2.6 board and telemetry, along with APM Planner 2.0 running on a Macbook Pro with Mavericks. I had everything working fine for the first couple days I had the system, I was able to flash the board and telemetry and I was able to write waypoints and such with the USB cable and telemetry system.

Then, all of the sudden, there was no communication happening between the APM and my computer. APM Planner doesn’t even recognize it when it’s plugged in with the USB cable. The telemetry radios connect to each other (have solid green lights) and when I hit the connect button in APM Planner they start transmitting data (blinking red lights) but APM planner doesn’t display any data. This led me to believe, after some research, that Apple’s sketchy FTDI Drivers had quit on me.

I researched for hours and tried every possible way to disable Apple’s driver and install FTDI’s genuine driver, everything from running software to disable Apple’s driver to running terminal sudo commands, but still nothing. I finally gave up on trying to install genuine FTDI drivers, and tried to reinstall Mavericks in hopes that I could bring back Apple’s driver that had worked for a little bit. That didn’t work. This is a major problem! I need to use my tricopter for a physics project for school due in 3 weeks, but I can’t use it at all!

Does anyone have experience with installing FTDI Drivers on Mavericks? I would REALLY appreciate some help on this, fast.

Verify your serial link between the two radios is working first, you can do that by connecting both radios to your mac at the same time. Run up two terminal windows. In one type screen 57600 /dev/cu.usbserial- and in the other type screen 57600 /dev/cu.usbserial-

You can find out the Ids by typing ls /dev/cu.usbserial*

If you can type in one window and see the characters appear in the other the APM2.6 is the problem area

If that the case, try reflashing the FW again

PS: also if you could post your ~/apm_planner/log.txt files that might be helpful as well

Thanks for the quick reply! I’m pretty sure the radios are working, I don’t have an FTDI to USB connector so I can’t connect the air radio to my computer right now to verify that. BUT when I go to 3DR radio config in APM Planner 2.0 It successfully loads both the radio’s settings, and they both match up with equal air speeds and everything at 57600 baud. I can reflash both radios also, and when I try to connect the red lights start flashing indicating they are transmitting data but the data won’t show. The USB cable connected directly to the APM 2.6 also does not work. The problem is the FTDI Drivers in mavericks.

Also, where can I find the log files you asked for?

Your logs are in ~/apm_planner/log.txt (i.e. your HOME directory)

THE APM2.5 does not use FTDI drivers when you connect over USB. you will notice if you do 'ls/dev/cu.* in terminal it will be makred as /dev/cu.usbserial not as /dev/cu.usbmodem as for the 3DR Radio. I use mavericks and the FTDI drivers are working for me ok.

I would suggest ‘ls /dev/cu.*’ and check the APM is appearing when you connect it over USB.

Where you able to flash the FW again. If you cannot, and you say you have previously, I would guess the board has failed.

Looks like the board has failed :frowning: Terminal won’t give me any result using that command, and I can’t flash the board. I’m guessing there’s no way to fix a failed board?

I found the log file, but the forum won’t let me upload .txt files, so I changed it to word and pages but word itsn’t allowed either and the pages file was too big. PDF also is not allowed. I tried copying and pasting it directly into here, but it exceeds the word count.

You just need to compress the text file to zip first (it keeps the forum size down)

I would recommend getting another board. It does seem that it’s failed. If it’s purchased from 3DR, contact and see if they can help

I had the same problem - the radio did now show up with ls /dev/cu.*.
Simply installing the driver (FTDIUSBSerialDriver_10_4_10_5_10_6_10_7.mpkg) solved the problem.