Servers by jDrones

Maverick : Help with initial use

@fnoop Hi! Just loaded Maverick and followed Quick Start setup instructions using a RPi 3 B+ with GPIO pins wired to Pixhawk 2.1. I get an Exception error when running mavproxy, so being relatively new at this, I’m hoping for some initial help to get me going. I tried reading through the older threads, but started to get a headache ; )

mavproxy.py --master=/dev/serial0 --baudrate 921600 --aircraft MyCopter

For starters, I’ll be happy just to talk to the fc. I haven’t touched the localconf.json file as yet. Many thanks

Hey @jax200! Maverick already has a mavproxy running, if you do maverick status you should see a list of services and their current status. They’ve changed for the upcoming 2.0 version but they look something like:

____________
Flight Controller
mavlink@fc           Mavlink (FC)              Stopped | Disabled
rosmaster@fc         Rosmaster (FC)            Stopped | Disabled
rosmaster@fc         Rosmaster (FC)            Stopped | Disabled
api@fc               MavAPI (FC)               Stopped | Disabled

In the current stable version instead of mavlink@fc it might be mavproxy@fc? Can’t remember exactly. The ports are listed here:
https://goodrobots.github.io/maverick/next/#/modules/mavlink

It’s really badly documented for people new to Maverick - that will improve in 2.0, which I hope to release over Christmas (finally, hopefully…).

1 Like

@fnoop Thanks for this. But I am still unclear why I cannot talk to my fc. I now have the following -

mav2

What is the proper command to start a mavproxy session if I am not doing this correctly?

regards

Also, on boot up why does the following message appear?

> "HARDWARE PLATFORM NOT RECOGNIZED"

So mavproxy is already running in the background - that’s what the ‘mavlink-router@fc’ is. If you do ps -ef |grep mavproxy you’ll see the processes. It’s running in a screen, so you can run screen -ls to see the screens and then screen -r <name> (replacing ) to get to the mavproxy console. Let me know if you have problems.

You probably can’t connect to your FC because the background mavproxy is already connected to it. Also I would start off with 115200 baud before moving upwards - raspberry in particular sometimes has problems at the higher rates.

Again, this can and should be documented better - and will be in 2.0 - we’ll add a proper users guide.

@fnoop Apologies for all the questions, but I’m just learning this. If I understand correctly, I only have a sitl instance running? Not sure what happened to the mavlink-router screen. How then to connect to the fc?


scrn2

@fnoop I did this

I tried this to get mavproxy --console and --map, but no luck

Your help is appreciated!

thx

Hey, oops you’re right sorry - mavlink-router is the default mavlink proxy. mavlink-router doesn’t have a console/‘screen’ available - it’s a simple proxy. From your maverick status output - your FC proxy is still running mavlink-router (mavlink-router@fc).
If you specifically want mavproxy, and looks like you’ve specified that in localconf.json, then you need to run a maverick configure to activate it - switch mavlink-router to mavproxy.
If you don’t specifically want mavproxy for your main FC proxy, I would just leave mavlink-router as is - it’s much lighter weight and simpler.

If you do activate it, then you can access mavproxy console through screen, but you won’t get any of the gui stuff. For that you’d need to switch off the built-in proxy altogether and run your own.

Just to re-iterate, Maverick has a mavlink proxy already running in the background (either mavlink-router, mavproxy or cmavnode). So you don’t run ‘mavproxy.py’ as it’s already running. This is normal in an embedded environment such as a UAV - you want the proxy running automatically as a service in the background. If you want to run mavproxy as a GCS (ie the ui stuff) - then you can run it, but just connect it to the existing proxy output port, which it looks like you’re doing. Your first screenshot above is successfully connecting to the running FC proxy and it looks fine. The second is also connecting fine but you’re getting a display error. This is because you’re ssh’d into your raspberry but without an X tunnel. From a linux desktop, you’d do something like:

xhost +
ssh -Y mav@maverick-raspberry.local

And then it should work. If you’re using windows, I’ve no idea how to setup an X server. You’d be better off downloading mavproxy for windows and connecting directly to tcp:maverick-raspberry.local:5770.

Hope this makes sense. It’s a bit complicated, because of the flexibility and modular nature of the setup. It needs to be simplified (which it has been a little in 2.0), but in particular documented better.

I understand now. Thanks again and thanks for your contributions to ardupilot. ; )

@fnoop OK I’m back. I commented out mavproxy in localconf.json, hence using mavlink-router running in the background. I can definitely ssh into maverick from Windows via Putty no problem. And as you mention, I should be able to talk to the fc straight-away from the maverick prompt once I log in without launching mavproxy. But - no luck. I guess I’m missing some fundamental step. I attempted a few simple commands but just get errors.

I also can get into Grafana - very cool indeed. But I don’t see any data at all.

Also, I can connect with mavproxy in WIndows to get a MAV> prompt, and issue commands.

1 Like

@fnoop Also… I started to poke around the vision services. Visiond shows “enabled”, but none of the services are started. I tried to start this but instead got this.visiond

To preclude my floundering about, perhaps you could provide initial direction? I did read the maverick webpage on vision, but not entirely clear with me.

1 Like

@fnoop Is development of Maverick continuing still? I noticed it’s been several months since the last commit. I’m interested in using it for my project, but I am unsure if anyone is continuing to work on it and it is still listed as being in beta.

Servers by jDrones