This is my first post on this forum, so I want to say hello to all :slight_smile:
I have a problem with the command COMMAND LONG - pixhawk with the firmware V3.4.1 arducopter.
I’m trying to get information for my OSD by sending MAV_CMD_SET_MESSAGE_INTERVAL. Always gets a response (by COMMAND_ACK) value of 3.
Is Command_Long is handled completely in this software ? (3.4.1)
Maybe someone can share dump, with correctly sent command_long data to pixhawk via uart?
I would add only as that by REQUEST_DATA_STREAM works OK, but because it has status deprecated - trying to use command_long.

1 Like

It’s the ‘old way’ for the protocol, but it’s not deprecated in ArduPilot.

I don’t think the new command long version is yet implemented either, hence why it rejects the call. Just search the ArduPilot code base and you can confirm easily enough.

I’ve encountered a related issue with my Arduino companion computer (via serial4) with my PixHawk controller on a Rover. Initially I was using SET_MESSAGE_INTERVAL to request messages at a greater rate however switched to trying REQUEST_DATA_STREAM as you recommended. I also noticed that adjusting parameters SR2 changes the message rate. I am trying to receive message #62 which I understand falls under the EXT_STAT parameter however from my serial monitor I only see #1, #125, and #152 messages arriving.

REQUEST_DATA_STREAM will only boost the rate that EXT_STAT is sent at correct? For now I am doing this manually with the parameters, but do you know why I might only be receiving 3/7 messages that I would expect from this stream?

Switching between auto an manual modes does not seem to change which messages I receive. Regardless, MissionPlanner correctly displays the wp_dist which is part of NAV_CONTROLLER_OUTPUT so have I misunderstood what messages are available via MavLink1 on Serial 4?