Mateksys CAN airspeed DLVR L431 causing other CAN nodes on the bus to fail to initialise

Hi there,
I’m part of a team developing a sub 25kg powered lift aircraft and we are making extensive use of CAN, via the L431 CAN nodes developed by Mateksys.
The problem I’ve run into is that when I have the Mateksys CAN Airspeed DLVR ( device plugged into our CAN bus, it causes our other nodes to be unable to initialise. It’s not all of the nodes, sometimes it’s just one of the other nodes on the bus.
The way we currently have our CAN architecture is as follows:
CAN bus 1:
3 CAN nodes controlling servos for our control surfaces.
1 CAN node for use of a GPS
1 CAN Airspeed sensor
CAN bus 2:
2 VTOL and forward propulsion can nodes with 3/4 connections each (total of 7 motors)

I’ve tried statically assigning CAN node ID’s and that had some success but started causing a “Duplicate node” error in mission planner. When I plugged into the CAN bus directly via droneCAN GUI I saw that one of the nodes (the node associated with the MP error) was failing to initialise, despite having a static ID. I’ve since reverted back to dynamic node ID’s. My way of getting around the issue so far is to unplug the airspeed sensor and then let everything else initialise and then plugging the airspeed itself in, which seems to work but is really inconvenient as it requires the bottom fuselage of our craft having to come off every single time.

Has anyone run into anything similar? Everything works fine when the airspeed isn’t plugged in, I’ve tried to run the airspeed device in it’s i2c mode plugged into a normal CAN node as well but same result. Is the airspeed sensor potentially just sending data in such a volume that it is overwhelming the bus?
Any tips or advice would be appreciated!

I should add, we’re using a cube orange for the above config