Matek M8Q-5883 Compass not Detected

Matek M8Q-5883 Compass not Detected

Matek M8Q-5883 is connected to Matek H743-mini FC: Tx2 and Rx2; SDA(Wht) to DA1 and SCL(Grn) to CL1

Mission Planner shows GPS connects to 12 to 14 satellites, Blue LED flashing on M8Q-5883, Solid Red also lit on M8Q-5883.




Tried: GPS_DRV_OPTIONS = 4 as suggested by rmackay9 in another post

Also tried: SERIAL_BAUD = 9600, 57600, 115200

The M8Q-5883 is not listed in the Mission Planner; SETUP; Mandatory Hardware; Compass Calibration section? I can’t run compass calibration?

MP Message: PreArm: Compass not healthy

ARMED: Bad Compass Health

In desperation I tried swapping SDA and SCL too.

None of those parameters have anything to do with the compass on the I2C port. I have that same combination.

I know I just want to make sure I left the impression that I gave it my best shot.

I have no idea what I should be doing to get help investigating the problem.

Any insights would be greatly appreciated. Thanks!

Can’t come up with much unless it’s a wiring issue. I have it wired the same way and it just worked from the get go.

I don’t suppose this helps much as it’s what you have described but just in case this shows my wiring. Red is going to the 4V5 pin

Out of curiosity what does your HW ID screen look like?

That’s the new V1:5 board. Wonder if that makes a difference. Supposed to be the same firmware though.

The new IMU is correctly identified at INS_ACC2_ID and INS_GYR2_ID on the SPI bus. That seems proof positive that the firmware is recognizing it, and the SPI bus shouldn’t be conflicting with I2C devices, anyway.

I recently took delivery of a Matek H743-Mini v1 board that was defective. The chip shortage is affecting electronics quite negatively, and QC has taken a turn for the worse. It’s entirely possible that the GPS/compass module is defective. I’ve never had any trouble with ArduPilot’s detection of supported I2C compass devices.

1 Like

Yuri_Rage, Thank you!

You were right, I have a defective M8Q-5883. A replacement M8Q-5883 showed up in the Mission Planner Compass List without anything more than the default parameters.

1 Like

Glad you got it sorted. I just set up a little quad with the exact same Matek GPS/compass module without incident as well.

I thought we had it but problems continued. Matek response was just as great as you Arducopter guys. After several diagnostic and trouble shooting steps they asked for pictures. Ughhhhh, my I2C wires between the M8Q-5883 and the fight controller were too long. Shortened the I2C wires to the length that came with the the M8Q-5883 and all of the issues were resolved.