Matek H743 Slim w/ Crossfire Nano Rx, Mavlink to PC Issues

I have a arduplane w/ a Matek H743 Slim w/ Crossfire Nano Rx. With Full crossfire TX / bluetooth connection to PC

Connection; works v well, i do have yappu lua running on my opentx radio, all works.
UART7 TX => RX crsf
UART7 RX => TX crsf
Connection; doesn’t very well
UART6 TX => RX Mavlink
UART6 RX => TX Mavlink
Some data gets through, but it’s very slow with lots of errors.

Also a weird issue, in configuration serial2 = UART6?? but this should be wrong?!
I did try brd_alt_config=1 but no change. Uart Mapping should be as below.

  • SERIAL0 = console = USB
  • SERIAL1 = Telemetry1 = UART7 (support CTS and RTS signaling)
  • SERIAL2 = Telemetry2 = USART1
  • SERIAL7 = USER = UART6 (TX only unless BRD_ALT_CONFIG=1, then RX available also)

UART6 should be = serial 7 in ardupilot config, but it is not?

BTW i do have another arduplane w/ matek F765 & a crossfire Nano diversity Rx which works very well! very happy with this setup. Have full mavlink data to PC v bluetooth, so i know this can work. Thus i’m sure my crossfire TX, and PC setup is correct.

Im kinda struggling through getting this working on a 743 myself, I tried serial 7 tx6-rx6 with brd alt config as 1 and crsf not working, i also tried serial 4 (tx3/rx3) and finally serial 1 (tx7/rx7) but im not getting rc.
the docs say it can work two ways either RCIN or serialxprotocol 23, but 23 is RCIN so its the same thing right?? were you able enable crsf in yaapu using a yaapu config tool lua? on my install that config tool is missing and i only have the yaapu gcs, yaapu debug and yaapu crsf debug, I can’t find anywhere to download the config tool…
Update, got it working eventually with baud rate at 420k and found the config screen by pressung telem button sometimes

We with the help of TBS customer service I worked out the issue.

This Nano Rx i have is bad. Installed a new Nano Rx all works!