Matek H743 slim undesired yaw movements

greetings …
i’m experiencing brutal yaw movements with my 5" quad :

F80 t-motors
F55A pro2 t-motor esc
matek H743 slim
M8n gps/compass module

  • watching the log data for rc control yaw (channel 4) so it’s normal, i mean the controller is not receiving an order to change the yaw …

  • YawErr in the log file is giving me some higher values around in some areas.

  • also you can notice the GyrZ to see the yaw movements (or twitches) …

what can be the problem !

this is a .bin log file , it’s a 25 seconds flight, at 13:44:57s a huge 360 degree turn ! (200ms to accomplish it !) :

this one is the parameters file :

thanks in advance.

today i checked the imu1 data (GyrZ) Vs imu2 data (Gyrz) :

i found that the imu1 measurements are glitching ! (check attached)

so i set the INS_USE to “zero” to use only the second imu or (imu2)

everything worked fine : now what is causing the first imu to do so ?!


Perhaps this is being addressed but it may not be the problem you are seeing.

1 Like

same problem here with Matek H743 Slim, on accelerometers ( gyros are ok, they match pretty well )
I’m going to try same dumping on FC supports to see if vibrations have an impact on this mismatches

IMU0 and IMU1 AccY ( same issue on X)

kindly check this link

i fly my little babe at home, so no gps … and look at the section between 3:00min and 4:00min (i’ve got a stable flight)

i tested the arducopter 4.2.2 but the problem is still the same !

the problem is with IMU0, compare Grz1 to Grz0 and see …

i think it’s a IMU0 driver related issue.