Matek H743-SLIM Setup Multiple Issues

I am attempting to configure Arducopter onto a Matek H743-SLIM V3 FC flashed with Matek H743 bi-directional Dshot Firmware and connected to a Holybro Tekko32 F4 4in1 50A ESC.

Unfortunately, I have the following issues which I hope someone can help?

  1. When a SD card is inserted, the FC won’t connect to Mission Planner, so I have done the setup without the SD card inserted.
  2. I have successfully configured CRSF, the GPS and compass but when doing an individual motor test e.g., ‘Motor A’ all motors will turn and the Throttle % setting has no effect.
  3. When connecting to BLHeliSuite32 I get this error message.


Here a link to the Parameter file

If anyone can help with this, I would appreciate it!

Parameter file isn’t of much value (disarm log would be better) but why do you have this set?
It seems that you are confusing Bdshot with 3D motor protocol. This is the parameter you need to set for Bdshot:

Moving forward whilst retaining problems is a bad habit to form. Why is the SD card problematic? Is it larger then 32GB? Formatted as something other than FAT32?

The SD card is one I used in a cube, 32GB and it had been reformatted it again in FAT32.

Hi Dave.
Thanks! SERVO_BLH_BDMASK=15 That fixed the motors! Just need to sort the SD card?

Try another card I suppose. Not sure if I have heard of that particular problem re: connecting with USB.

SD Card all sorted. Thanks

I came across this issue on the forums, and was wondering if there is any consensus on SD card GB size/formatting that is best for Ardupilot. I teach a course where we are building quads using this same FC and I have had multiple students with issues where the FC won’t boot properly with the SD card inserted, but will boot with the card not inserted - I don’t understand what else could be at play here, we’ve tried different SD cards of varying capacities, but all less than 32GB, different formatting (FAT32 vs FAT), and still no luck figuring out what the issue is, it just seems random. We even tried different versions of the firmware - latest stable as well as 4.3.4 (because I got that to work earlier this year) We’re using H743-bdshot version of the firmware. @Peterarnold what did you do to get the SD card working?

I use those boards and the same version of firmware and have never had a problem related to the Sd card. Think I have a different card in each FC but the one that’s readily accessible is a Sandisk Ultra 16 gb formatted FAT32. Nothing special.

Thanks @dkemxr I was told on the AP Discord that Andy Piper has flown this FC with his SD cards on exFAT, so I may try that as well, as we’ve been trying FAT32 and FAT formatting so far. Other than that, I’m at a loss right now - hoping it’s not multiple bad FCs, but I would think that’s unlikely.

I think it unlikely too. I have heard of one (1) Matek H743 FC (don’t recall which version) on here that was proven to be defective.

That’s good to hear! Thanks @dkemxr

@dpapworth. I ended up damaging that board (too much fiddling) but replaced it with an identical H743 SLIM and put one of these cheap SD cards in it and it works perfectly.

Thanks for getting back to me on this. I’m glad to hear that you got it working - hopefully we can do the same. :slight_smile:

I had recently a cheap no brand μSD on this same controller. I think to remember that everything worked except MavFTP. Everything worked with a branded one.

Thanks for the tip! I’ll check MavFTP with the SD cards we’re trying as well.