Matek h743-slim: Freeze after boot / solid red LED


I have the problem that my FC freezes after boot and just shows solid RED LED.
It´s not possible to connect with GCS (USB and telemetry radio). Same problem when powering FC via USB.

I updated yesterday to Arducopter 4.0.7 and everything worked great - did also some test flight.

Today I did some tests with fport and telemetry script and also that worked. My only problem was that telemetry was not working when I put my frsky archer m+ output to "FBUS (F.PORT 2.0), but FPORT worked.

Suddenly the FC was not booting anymore. I checked SDCARD and downgraded back to 4.0.6, but still the same problem.

I can´t find any information about that problem and I also don´t understand the beep codes.
Here is a short video showing the boot sequenze.

Google Drive video link

Any idea whats wrong?



1 Like

This board has had some issues with flash corruption for which there are fixes in 4.0.7. What I suggest you try is wiping the flash by first loading 4.0.7 plane and then 4.0.7 copter again. You will need to reset your parameters afterwards.

1 Like

Thanks!! That solved the problem!

So now I can continue to find out why FPORT 2.0 is not working.
No idea if that has any practical advantages, but I don´t understand why it is not working.