Matek H743 Initializes only after sitting for 15 minutes

I setup my H743 with m8q-can and r9 F.Port receiver.

I flashed the 2mb blank file with STM32CubeProgrammer then 4.1.0 beta arduplane_with_bl.hex. I have tried various stables and betaflight as well and have the same issue.

Basically it always goes to the bootloader (solid red and blue leds). If I let it sit for about 15 minutes it will boot arduplane.

When it does, I now can’t get my M8Q-CAN gps/baro detected. I’m debating ordering an F765 and letting this one sit for awhile until I can figure it out. Anyone have any ideas? I’ve checked the board and don’t see any issues.

I was able to get the board to work after flashing some more and getting lucky. When I connect USB or a battery it initializes instantly. So this board was just being a PIA straight from Matek.

Hoping I can figure out this GPS today. The cable seems fine but I found someone else had issues with continuity from the included cable. The only spare cable I have that will work would need to be used for MSP. I have a few HC-05s I could maybe make work for flashing the GPS firmware (I doubt mine shipped with the latest firmware supporting MSP).

I am in the same boat. H743 slim fport r9 matek m9n uavcan. Flew ok on betaflight. Won’t initialise on ardupilot. Never used ardupilot before so may be newbie issue. If you have got it working can you share settings?

Try flashing the ArduPilot bootloader only then flashing the nightly with bootloader

  • Flash 2mb empty file using STM32 Programmer (the blank file is on github)
  • Flash bootloader only
  • let it boot once and it will sit there like notmal
  • Flash latest firmware with bootloader one last time using STM32 Programmer

Write down all of your serial mapping and ArduPilot variables. IE if your r9 is on tx6 it will be serial7. Then all your fport settings, gps, etc. Reboot and calibrate and then let it sit again. I had to do it like 20 times before it worked - I think there is a memory allocation issue or something.

Another issue I have is the cable for the USB board had a bad connection. Check on the cable while your at it.

Also recheck your board for any issues with weak solder joints. It was a real pain for me. I could only get CAN to work initially so I had to wait for a usb to ttl to flash the latest firmware on my GPS and switch to MSP instead of CAN. Using CAN introduces too many variables.

At the end of the day I wish I had used an f765 but it’s all working great now.

Oh also I switched to using a small battery while flashing to make sure there weren’t any power issues