MATEK F765 GPS Issue

I am using F765 FC
I have connected GPS to TX2, RX2 (Tx - Rx, RX - Tx) port wire connection is correct I have checked it properly. The soldering of wire and pins are also done properly. Battery 3s and USB connection for power.
(serial 3 = set to 5 ). GPS is new and working checked with other FC like ( APM 2.8)

Still, I am getting no GPS on MP. Though compass is working fine. GPS is showing a solid red LED.
pleas someone help.

Are the SERIAL3 parameters set for GPS?

Yes set to 5 for gps protocol

Most modules blink blue when receiving sats. Does this one?

Mine ist working fine with
if you are sure that Rx/Tx is not accidentally plugged in the wrong way, I would connect the GPS to pin Tx3/Rx3 with
to exclude a hardware failure on the Rx2/Tx2 Pins.

Normal in Perfect condition it gives blue led
But I am only getting red led means no sat communication

Ok i will try that idea tomorrow .

You connect your GPS to Tx 2 and RX 2 right ? The main Gps 1 USART PORT As given in Matek F765 official website .

Was it working fine or you used different USART port

Attach your parameter file, perhaps something to see.

Correct - to the pins labeled Tx/Rx2 with serial3 parameters as mentioned above. As Dave has already written, your parameter file would be helpful.


this is the para list

parameter.param (23.0 KB)

Set only SERIAL3_PROTOCOL to 5 (if the GPS is connected to TX2/RX2). You still have GPS configured on SERIAL2, 3 and 4 …

1 Like

I have already done that. set all the serial to -1 (none).
only serial 3 is set as 5 ( GPS )

I am using (ublox NEO 7M ) is there any compatibility issue with that series?

Did you only try this indoors, or did you put it outside in the open air for 15 minutes?

finally, it is working now. I have done a full-chip clean and then install the new plane 4.0.9 firmware again on the FC.
Now It is working fine but I am getting ( GPS = no fix ) issue what should I do about that.

Get a new GPS module? 7M is old tech.

Nevertheless, it must work. Unfortunately, @sainath_desai does not write whether it has tried outside.

i have same issue on omnibus nano v6. i tried everything, from swapping cables to changing ports, to trying various params (options etc) nothing worked. If i flash INAV, i can get it working thoug… however not with arduplane. PS mine is a M8N