MATEK F405 Wing - Current Sensor Battery Monitor Setup

Hello. I’ve been exploring the new integration of F4 Omnibus boards within the ArduPilot ecosystem. I am currently using the latest version of ArduPlane 3.9 and the MATEK F405 Wing flight controller. All installed and works flawlessly except for the battery monitor/current sensor. As I understand, this setting comes disabled which requires manual enabling and pin setup within the parameters. I tried following the F4 Omnibus instructions for setting up the current sensor in the Ardupilot Wiki but no dice. I’m guessing there are different settings specific for the MATEK F405 Wing board perhaps? If anyone can assist or provide direction I would greatly appreciate it.

Thank you.

1 Like

it should work out of the box, the params are:



Actually BATT_AMP_PERVLT should be 31.5 according to Matek website, but that is minor issue, the best to check and calibrate anyway for more accurate reading.

Basic params and specs can be found on Matek website in Ardupilot Tab of the board, if you would need them again in the future.
and of course on ardupilot website

@iampete @spider72

Thank you both for your response! I greatly appreciate your assistance. I am still a novice with the ChiBios side of ArduPilot. I will give it a try tonight and advise.

Again thank you!

@spider72 @iampete

Thank you for your direction. I just tried it and worked like a charm. I’m not sure why out of the box it did not work. The only different thing I did is installed the firmware from the “latest” folder in lieu of the "stable’ folder.
If I can pick your brain on one last item: Have you setup crossfire using full telemetry in lieu of SBUS?

Thanks in advance for your assistance.

UPDATE: Scratch that. I was able to make it work. It was all relative since it wasn’t detecting current before, it wasn’t sending any telemetry from the current sensor.
Do you know if anyone has been able to connect radio telemetry radios (3dr or RDF900+) to the Matek boards on ChiBios?

Telemetry radio should work by default on UART1 (Serial1), the one below GPS connection.

Thanks @spider72 for your response. The typical radios require two specific ports that I don’t see where to locate on the UARTS: RTS & CTS. Is there a special configuration I need to make for these two? I reached out to Matek Support on this and they mentioned there’s no info on their end on successfully installing telemetry radios with their product. I have a pair of RFD 900+ that I’d love to continue using with the Matek board. See image reference below.
Lastly, is there a servo order diagram/list that illustrates the pin location of the control surfaces? For example, we know on the other boards like Pixhawk, 1=Aileron, 2=Elevator, 3=Throttle, 4=Rudder. Since the Matek board is arranged differently (1=Motor1, 2=Motor2, Servo3, Servo4, etc) I was unsure where to locate the various surfaces.
Thanks again for your assistance through this.

you don’t need to connect them

you can put them where-ever you like and change the servo functions to match

Thank you again for your patience and assistance. I’m working on it as we speak and will give it a shot.

I have documented the process here for connecting a SiK telemetry radio to SERIAL1:

This great! Thank you for taking the time and sharing.