Servers by jDrones

Matek F405-STD ChibiOS issues

mission-planner
chibios
matek

(Rolando G) #1

Hello guys,

I have a Matek F405-STD board and I’m having issues on Mission Planner. I spent the better day of yesterday figuring out a Windows driver issue and finally got it connected to MP. Now while running initial setup it just hangs. The board has LEDs ON and MP is unresponsive. I can’t calibrate compass or accelerometer. I have to reboot board and MP.

I’ve tried flashing it via BF with the latest & stable builds of copter and plane for “Matek F405” and “Matek F405-STD” and I keep getting bad results. Any help?


(Peter Hall) #2

your flashing latest? The .hex with bl using betaflight configorator? Only difference between -STD and not is the default parameters for ahrs orientation so it matches the arrow on the board.


(Rolando G) #3

Yes, I wonder if this issue is linked again with the drivers.


(Peter Hall) #4

are you on the latest beta of mission planner? help -> check for beta updates


(Rolando G) #5

I clicked that and then tested again, and nothing


(ppoirier) #6

I experienced a similar problem after flashing the xxx_bl.hex and I resolve by changing USB port on my Wind10. Look like its kinda blacklisted on the port after flashing…


(Rolando G) #7

@ppoirier @iampete

I figured this one out. I first connect the battery, then after all of the beeps connected USB. This time it worked like a charm with ‘latest’ firmware 3.70.

I figured this out because while running iNav, if I didn’t connect battery first and then USB I would get a barometer error. This was similar to ArduPilot’s barometer error too. I tested a new F405-STD board with nothing soldered onto it and it didn’t have any issues on initial setup. I decided to give this older board a go (this one completely soldered to motors, etc). It worked out.

There are still a few things to iron out: for example it doesn’t pick up the change in frame (from Quad X to Quad H). I’ll have to change it in the params and hopefully that works. Same issue with setting an arm RC channel, I had to do in params (even though there were no options showing).